Support » Plugin: Popular Widget » PHP 7

  • Hi!

    I’ve tested all my plugins with this PHP linter:
    https://wordpress.org/plugins/php-compatibility-checker/

    Unfortunately I found a problem with your plugin:

    FILE: /home/kristia2/www/filmpuls.ch/wordpress/wp-content/plugins/popular-widget/_inc/functions.php
    —————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————
    22 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    —————————————————————————————————

    FILE: /home/kristia2/www/filmpuls.ch/wordpress/wp-content/plugins/popular-widget/popular-widget.php
    —————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————
    53 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    —————————————————————————————————

    Would be great if you can fix this!

    All the best,

  • The topic ‘PHP 7’ is closed to new replies.