Support » Plugin: PWA+PHP Picasa Web Albums for WordPress » Google Authentication Problem

  • Resolved claridgematt

    (@claridgematt)


    Hi,

    I’ve just installed this plugin and when trying to complete Step 1 of the setup, to authenticate with Google, I am receiving this error:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site “http://co.uk” has not been registered.

    Google reports that this authentication method has been deprecated.

    Is there a way around this problem? I don’t particularly need access to private albums, so this step is probably not required, but the plugin demands it…

    Any help would be appreciated.

    Thanks
    Matt

    https://wordpress.org/plugins/pwaplusphp/

Viewing 15 replies - 1 through 15 (of 110 total)
  • Jeroen

    (@jeroenonstenk)

    Oh, I really wish there was a solution for this. For some months I’m waiting/hoping/searching for a way to solve this problem!

    Google has changed its authentication process: https://www.google.com/landing/2step/

    Yes, that’s pretty much what I said. The problem is that the plugin hasn’t been updated to take account of this and unfortunately the plugin seems to be dead, or at least unsupported, so it doesn’t look like it will be.

    Shame though.

    Jeroen

    (@jeroenonstenk)

    The latest update of the plugin was in november last year. So it doesn’t seem to be dead or unsupported. But this issue seems to be there for a couple of months now.

    Maybe @smccandl doesn’t know how to solve it. Or it doesn’t have any priority for him anymore. Either way it’s too bad that he doesn’t give anyone a heads up.

    Strange. I just downloaded this plugin and it works fine for me with the two step authentication method from Google.

    Plugin Author smccandl

    (@smccandl)

    Hi all, the message you are getting:

    The site “http://co.uk” has not been registered.

    Is typically solved as described here, basically you need to register your WP domain at https://accounts.google.com/ManageDomains.

    Have you already tried that?

    The deprecated message is really just a warning that this AuthSub method of authentication will stop working eventually, but it still works fine as noted by Peter.

    The method authentication method replacing AuthSub is called OAUTH2. I have a version of PWA+PHP that sort of works using OAUTH2 but it’s a hassle for users because you need to go create a “Web Application” and generate secret user tokens, etc etc and then manually add them on the plugin config page.

    Since AuthSub is still working and much easier for users to setup, that’s the method used by the plugin.

    Scott

    hello @smccandl,
    same problem here. Once I get to this page : https://accounts.google.com/ManageDomains, how do I bypass the warning about oAuth1 to continue?
    thanks

    Ok i figured it out with this hack of sorts.
    When you arrive on the Google page saying “The page you have requested cannot be displayed…”
    Look up in the address bar and you will see your website address at the end of the url. Find the bit of the address of your site : “http%3A%2F%2F” and copy paste that bit so you have it twice like so: http%3A%2F%2Fhttp%3A%2F%2F”
    Then press enter, you will now get the page where Google asks you to authorize, but don’t click “authorize” yet. You have to again look at the address bar and you will see https//www…. it is missing the “:” which you have to place so that it reads “https://www.” Then click enter and you will be redirected to finish the PWAPHP setup back on your blog.
    I can’t believe it worked.

    Great work on this plugin. I’m looking to replace another plugin that uses AuthSub and it stopped working but the dev isn’t responding.

    @smccandl AuthSub will be turned off next month. When will you be updating to use Oauth?

    “Starting April 20, 2015, AuthSub will no longer work for Google Accounts.”
    https://support.google.com/accounts/answer/6140402

    Plugin Author smccandl

    (@smccandl)

    Version using OAuth2 is in the works and will be ready before AuthSub stops working.

    Scott

    Plugin Author smccandl

    (@smccandl)

    All, v0.9.9 beta with support for OAuth2 is available for download and testing at:

    http://pwaplusphp.smccandl.net/code/pwaplusphp_v0.9.9_beta.zip

    You will need to create a “Project” in the Google Developer Console and provide the Client ID and Client Secret to PWA+PHP. The plugin walks you through all the steps.

    Please let me know how it goes.

    Scott

    Was going great until clicking step 2 gave me a permission problem:

    “You do not have sufficient permissions to access this page.”

    URL: MYSITE.com/wp-admin/options-general.php?page=pwaplusphp&loc=step_2_project_creds

    I’m running a multisite install, and I’m a super admin. So that was an odd error.

    Changed the URL to MYSITE.com/SUBBLOG/wp-admin/options-general.php?page=pwaplusphp&loc=step_2_project_creds

    and the page came up just fine.

    Same problem and solution on step 3. On step 3 the redirect url is incorrect as it doesn’t list the subblog.
    For example
    REDIRECT URIS: http://www.MSINSTALL.info/wp-admin/options-general.php?page=pwaplusphp

    SHOUDL BE: REDIRECT URIS: http://www.MSINSTALL.info/BLOG1/wp-admin/options-general.php?page=pwaplusphp

    After step 3 I bounce to google and see the permissions screen but after accepting and coming back to the wrong URL, changing it to the subblog shows:

    “Install Step 4: Failed!
    Got the following response:
    { “error” : “unauthorized_client” }”

    P.S. your steps are clear and well written. Easier than other plugins that walked through the developer console.

    Plugin Author smccandl

    (@smccandl)

    So:

    1) Need to support multisite — will work on this.
    2) For the unauthorized client message, this is probably also related to multisite — due to the wrong redirect_uri the plugin instructed you to enter. Does the redirect_uri in the Project on developer console match the one in the URL displayed in the address bar on the page where you click to Grant Permission?

    Scott

    No they didn’t, I tried changing the uri in the dev console to match the subdomain to see if it would work but it didn’t help.

Viewing 15 replies - 1 through 15 (of 110 total)
  • The topic ‘Google Authentication Problem’ is closed to new replies.