Support » Plugin: PWA+PHP Picasa Web Albums for WordPress » Google Authentication Problem

  • Resolved claridgematt

    (@claridgematt)


    Hi,

    I’ve just installed this plugin and when trying to complete Step 1 of the setup, to authenticate with Google, I am receiving this error:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site “http://co.uk” has not been registered.

    Google reports that this authentication method has been deprecated.

    Is there a way around this problem? I don’t particularly need access to private albums, so this step is probably not required, but the plugin demands it…

    Any help would be appreciated.

    Thanks
    Matt

    https://wordpress.org/plugins/pwaplusphp/

Viewing 15 replies - 16 through 30 (of 110 total)
  • Plugin Author smccandl

    (@smccandl)

    Ok, both issues should be resolved.

    New version of the zip file is available at the same location.

    Multisite issue should be ok now that the code uses wordpress site_url function. unauthorized_client message was displayed because I accidentally left my client_id hardcoded in step 3.

    Scott

    That google connection worked great! (Step 8 should just be your root, google doesn’t allow a path or wildcards)

    However, you plugin didn’t work after embedding [pwaplusphp] on a page. 🙁

    Plugin Author smccandl

    (@smccandl)

    Thanks – I corrected the value printed at step 8 to include the root only.

    Going to need some more info to figure out why nothing is displayed. Can you open up pwaplusphp.php and add this:

    echo $addressData;

    in functionn doCurlExec after:

    $addressData = curl_exec($ch);

    Should be line 75.

    Scott

    Hi,

    Is this update almost ready? Just setup PHA-PWP and was wondering if I should switch.

    Thanks.

    Plugin Author smccandl

    (@smccandl)

    By all means, please grab the beta version and test it out. Once I get some feedback that it’s working well, I will publish it.

    http://pwaplusphp.smccandl.net/code/pwaplusphp_v0.9.9_beta.zip

    Thanks. I have to uninstall the existing correct? It doesn’t see it as the same plugin.

    Looks like we have till the 20th of this month.

    hi,

    i have also this error on the end:

    “Install Step 4: Failed!
    Got the following response:
    { “error” : “unauthorized_client” }”

    is there a solution?

    Plugin Author smccandl

    (@smccandl)

    Yes – found and fixed the issue. Please remove and re-install v0.9.9.

    oh great, thank you!

    now you can sell me the pro version!? 🙂

    I had the Step 4 error as well. Delete the plugin and reinstall. (note sure why the version # was not changed to 0.9.10 to force update) but this did allow me to get past the “Install Step 4: Failed!
    Got the following response:
    { “error” : “unauthorized_client” }”

    However, now my page shows no albums when I add the shortcode [pwaplusphp]

    I tried a different shortcode [pwaplusphp album=”random_photo”] and the page state this was only available in the pro version. When I go to the demo page: http://pwaplusphp.smccandl.net/pwademo.php and enter my username the albums display fine.

    Also, on the right side of the my settings page even though I have loaded v 0.9.9 it is showing PWA+PHP v0.9.7

    Please provide suggestions to deal with this. Thank you.

    I hope I’m right here.
    I could set up the OAuth2 and it works.
    But 1-2 hours later, the galleries are empty again.
    If I then “Reset Token” begint do it all over again.

    Did I forget something so that the gallery will be displayed permanently?
    I have the latest version installed by 19/04/2015. v0.9.9 after the last correction.

    Thank you for your help.

    Plugin Author smccandl

    (@smccandl)

    @rjdougan: That was an oversight, next update I will use .10. Not sure where you are stuck. Did you try the ‘Reset Token’ link? If you click that link and then reload the page, you should be able to go through the authentication process again.

    @feliciars: In the OAuth2 model there is a concept of a “refresh token”. Every hour or so the authentication expires and pwaplusphp must use the refresh token to re-request access. It sounds like maybe this is not working for you — you shouldn’t need to use the ‘Reset Token’ link to get it working. Will need to enable some debug to see where you are getting stuck.

    Scott

    Hi Scott,
    sorry for the question but it’s about this debug information?

    [20-Apr-2015 14:36:55 UTC] PHP Notice:  Undefined variable: PRO_VERSION in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/pwaplusphp.php on line 318
    [20-Apr-2015 14:36:56 UTC] PHP Notice:  Undefined variable: now in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 35
    [20-Apr-2015 14:36:56 UTC] PHP Notice:  Undefined index: picasaweb_user in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 44
    [20-Apr-2015 14:36:56 UTC] PHP Notice:  Trying to get property of non-object in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 49
    [20-Apr-2015 14:36:56 UTC] PHP Notice:  Undefined offset: 1 in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 95
    [20-Apr-2015 14:36:56 UTC] PHP Notice:  Undefined variable: out in .../htdocs/feliciars/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 427

    Thanks for your help
    Philipp

    I am getting a very similar error see below. See no albums or images display

    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined variable: PRO_VERSION in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/pwaplusphp.php on line 318
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: hide_albums in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 8
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: images_per_page in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 43
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: image_size in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 44
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: thumbnail_size in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 45
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: picasaweb_user in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 46
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined variable: uri in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 53
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined offset: 1 in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 53
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Trying to get property of non-object in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 66
    [20-Apr-2015 15:25:59 UTC] PHP Notice:  Undefined index: pg in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 117
    [20-Apr-2015 15:26:14 UTC] PHP Notice:  Trying to get property of non-object in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 329
    [20-Apr-2015 15:26:14 UTC] PHP Notice:  Undefined variable: total_images in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 331
    [20-Apr-2015 15:26:14 UTC] PHP Notice:  Undefined variable: album_count in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 331
    [20-Apr-2015 15:26:14 UTC] PHP Notice:  Undefined variable: out in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 336
    [20-Apr-2015 15:26:14 UTC] PHP Notice:  Undefined variable: ALBUM_COUNT in /home/xxxxxxx/public_html/wp-content/plugins/pwaplusphp/dumpAlbumList.php on line 346

    Plugin Author smccandl

    (@smccandl)

    The php notices are nothing to worry about, but they shouldn’t be displayed. I’ve released a new version (0.9.10) that suppresses them. Please completely remove v0.9.9 and then install v0.9.10.

    @feliciars, if the refresh token fails a message should be printed to the screen. Are you seeing it?

Viewing 15 replies - 16 through 30 (of 110 total)
  • The topic ‘Google Authentication Problem’ is closed to new replies.