Support » Plugin: PWA+PHP Picasa Web Albums for WordPress » Google Authentication Problem

  • Resolved claridgematt



    I’ve just installed this plugin and when trying to complete Step 1 of the setup, to authenticate with Google, I am receiving this error:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site “” has not been registered.

    Google reports that this authentication method has been deprecated.

    Is there a way around this problem? I don’t particularly need access to private albums, so this step is probably not required, but the plugin demands it…

    Any help would be appreciated.


Viewing 15 replies - 31 through 45 (of 110 total)
  • hi,
    I follow all the steps but images are not showing, I reset token but still nothing.
    any idea?

    it works now.
    first time I use a google developer account which was different from the google account I use for Picasa, now google developer account and picasa use the same google account.

    Hi Scott,
    Unfortunately, I do not see any message.
    But when I run on one side [pwaplusphp], the other galleries are displayed again. Without “refresh token” to use.
    Uses [pwaplusphp] perhaps a function that [pwaplusphp album = “Album Name”] does not call?
    After 1 hour is gone everything. I do not want [pwaplusphp] use, since there galleries are that should not be publicly visible.

    Thank you for your work.

    2 hours later… all pictures are goned!

    I reset token and it works again!
    it’s not really good if I need to reset token everytime!!!

    I have remove the old version and reinstalled 0.9.10 After a period of time the images finally are showing. Will continue to monitor to make sure they don’t disappear.

    Thank you for addressing this issue.

    disinstall version 0.9.10 and reinstall this version will solve my problem too?

    Plugin Author smccandl


    @jroy, please give it a try. If not I will need to send you a special debug version of the plugin to help figure out where the problem is.


    Plugin Author smccandl


    @feliciars, both types of shortcode are setup to refresh the token automatically if it has expired. I will need to post a debug version of the plugin for you to use.


    I uninstall 0.9.10, delete all files and then install again.
    I key in the client ID and client secret, finish all the steps and it doesn’t work.
    I request again the token and this time it doesn’t work too but I have this error message :
    Warning: substr() expects parameter 3 to be long, string given in /home/naruwan/www/wp-content/plugins/pwaplusphp/showAlbumContents.php on line 286

    you can see it here:

    sorry, it’s just warning message, I see the images after the list of warning messages.
    but before this warning wasn’t show, why it appear now?

    I add this line in config.php: define(‘WP_DEBUG_DISPLAY’, false);

    but warning still appear 🙁

    ok I also need to add this line in config.php: @ini_set(‘display_errors’, 0);

    maybe it can helps.

    now I will wait for 1 or 2 hours to see if my photos disappear again!

    To give some positive feedback, I just installed version v0.9.9 (first time install) on a single site using the new Google token system and it went quickly and easily without a hitch. Looks like the glitches should be out for everyone else soon, too.

    Thanks, Scott!

    –Rich Wagner

    50 minutes after my last post I come back again to tell you that all pictures are disappear again!

    wildnaturephotos: it still works 1 hour after?

    It’s working a day later… I’ll leave a window open and see that happens after an hour.


Viewing 15 replies - 31 through 45 (of 110 total)
  • The topic ‘Google Authentication Problem’ is closed to new replies.