Support » Plugin: User Registration & User Profile - Profile Builder » Wrong credentials blank page

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi there,

    Since this is looking a lot like a conflict with some other code, please do the following conflict test:

    Briefly disable all other plugins and enable the Twenty Nineteen default theme.

    If this solves the problem, as it likely will, enable everything one by one, checking each time to see when the problem returns.

    When you find out what the conflict is, please let us know so that we can take a look at it.

    With the best of regards,
    Gabriel

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi again,

    Sorry for bumping, but I have just checked out your login form at the link that you provided.

    I have entered some random credentials and it reloaded the page, with an error message saying “ERROR: Invalid username or email. Lost your password?”

    So all appears to be working properly.

    Can you reproduce this experience?

    Best regards,
    Gabriel

    Hi,

    Thank you for the reply.

    Unfortunately, this is a production site, so I can’t easily disable plugins to check for issues. Some of these will lose settings if I do.

    I was fiddling with optimization plugins, so you might have tried it in a moment none was present, and somehow it worked. Currently, I’m still getting a blank page.

    Now the site only has WP Fastest Cache working since Autoptimize and Clearfy break the code and their exclusions don’t work. WP Fastest Cache (free version) is set to minify HTML and CSS only. Not touching JS. But disabling WP Fastest Cache does not solve the issue.

    I’ll try disabling stuff overnight in the next few days to see if the cause is in some other plugin.

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi there,

    Again I have tried it, and again it works:

    http://gab.ro/temp/works.png

    It says “ERROR: Invalid username or email. Lost your password?”

    If you get inconsistent behavior like this, caching is most likely the issue. Have you tried a test to disable all caching and see if this fixes the problem? If so, you’ll need to tweak the caching settings.

    With the best of regards,
    Gabriel

    Hello,

    Thanks for the tip. Didn’t work. I even added the login page to the cache exclusions.

    Nevertheless, I found what was causing it. You might want to warn other users or mitigate the underlying issue. This site uses the iThemes Security plugin that has the option to Filter long URL strings (under System Tweaks). The password error URL is really long because of the error code. I disabled the option in iThemes and now the login error displays correctly.
    Solved!

    • This reply was modified 2 months, 1 week ago by  finomeno. Reason: typo and link
    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi there,

    Glad to hear and thanks for letting us know.

    With the best of wishes,
    Gabriel

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.