Support » Plugin: WP-Strava » Version 1.1 Broken

  • Resolved marcushe

    (@marcushe)



    Hello, after updating to version 1.1 of wp-strava, my entire WordPress site crashes when any page is loaded with the error:

    Parse error: syntax error, unexpected ‘:’ in /home/content/52/5226552/html/wp-content/plugins/wp-strava/lib/LatestMapWidget.class.php on line 63

    Reverting to 1.0 resolves the issue.

    Any ideas?

    Thanks!
    – Marcus

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author jrfoell

    (@jrfoell)

    Thanks Marcus!

    There’s a PHP 5.3 feature that is on that line of code. I’ll remove it in version 1.2 to ensure PHP 5.2 compatibility. As a heads up, WP recommends a much newer version than 5.2, plus there are several performance gains to be had by upgrading: https://wordpress.org/about/requirements/

    Plugin Author jrfoell

    (@jrfoell)

    Marcus, I updated your change in version 1.2.0 which went out today. Let me know if you have any other issues!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Version 1.1 Broken’ is closed to new replies.