To run WordPress we recommend your host supports:

  • PHP version 5.6 or greater
  • MySQL version 5.5 or greater

That’s really it. We recommend Apache or Nginx as the most robust and featureful server for running WordPress, but any server that supports PHP and MySQL will do. That said, we can’t test every possible environment and each of the hosts on our hosting page supports the above and more with no problems.

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

Ask for it

Here’s a letter you can send to your host; copy and paste!

I'm interested in running the open-source WordPress <https://wordpress.org/> blogging software and I was wondering if my account supported the following:

  • PHP 5.6 or greater
  • MySQL 5.5 or greater
  • The mod_rewrite Apache module


Not required, but recommended for better security

Hosting is more secure when PHP applications, like WordPress, are run using your account’s username instead of the server’s default shared username. The most common way nowadays for hosting companies to do this is using suPHP. Just ask your potential host if they run suPHP or something similar.

Why do we support older versions?

We strongly recommend the latest versions of PHP and MySQL, but we understand that this isn’t right for everyone, and that sometimes hosts can be slow or hesitant to upgrade their customers since upgrades to PHP and MySQL have historically broken applications.

WordPress will always work on the latest versions of PHP and MySQL, which are often faster and more stable.