Support » Fixing WordPress » Update Now button inactive

  • Resolved avfadagio

    (@avfadagio)


    On one of my WordPress sites, I can’t press the Update Now button to update to the latest version. It is there but it is inactive. I’ve disabled all plugins and tried a standard theme but to no avail. In addition, I can’t save my Contact 7 contact form. The Save button is inactive. I make a change and can’t save it. If I refresh the page it asks if I am sure I want to leave without saving, but I can’t save. Seems like a pattern.

    What would cause these buttons to not be active? My other two sites work fine, all hosted by the same provider.

    It used to work. I’m only one WordPress version behind, so I know I’ve updated before.

    Thanks.

    • This topic was modified 1 month, 4 weeks ago by Steve Stern.
Viewing 15 replies - 1 through 15 (of 37 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Thank you. I will give that a try.

    I just noticed that I can’t even hit ‘Save’ in Settings, General either.

    I was able to upload the latest WordPress successfully using your excellent instructions and I can see that the new version is running, but I still can’t hit save in the Settings, General page. Or Save Contact 7 pages.

    I’m obviously admin, but is there some other setting that restricts saving?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    To do so, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and edit the file with a plain text editor.

    For details: https://wordpress.org/support/article/editing-wp-config-php/#disable-javascript-concatenation

    • This reply was modified 1 month, 4 weeks ago by James Huff. Reason: fixed "plain text editor" link

    Thanks. Tried that but still no luck.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    That’s really odd.

    First, please make sure that your browser is up to date: https://browsehappy.com/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    I will try those. I probably won’t have time tonight – need to go to work, but I will keep you informed as I try these.

    Thanks so much for your great suggestions – very much appreciated!

    I tried it on other computers, even my iPad, and still can’t get those buttons to work.

    The problem showed on my site so I used wp-staging to make a staged site and that’s the one I am trying to correct at the moment. I disabled all the plugins again, changed the theme. No luck.

    The Bulk ‘Apply’ button is grayed out as well.

    I am hosting on goddady, but I have two other sites hosted there as well. Both of those work fine.

    Everything else about the site (www.solideogloriainstitute.org) seems to work fine.

    This is very perplexing.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    So, the problem is only on the staging site? It works fine on the live site?

    No, it fails on both. I saw it on the live site originally then created a staging site so I could play around with it without worrying about the live site. So whatever was in the live site copied over to the stage site.

    About the only thing I haven’t replaced is the wp-config file.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    It looks like you’re with GoDaddy. Are you with their Managed WordPress product?

    No. Not the managed product. I just use them for hosting.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Both before and after you try to click any non-working button, do you see any errors in your browser’s console? https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/

    Using Chrome, this is all I see –

    jquery-migrate.js?ver=1.4.1:23
    JQMIGRATE: Migrate is installed with logging active, version 1.4.1

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ugh, I’m running out of ideas here. I’m going to ask my colleagues to jump in if they have any.

    Meanwhile, as you sure you checked with all browser add-ons switched off? Including ad/tracker blockers?

Viewing 15 replies - 1 through 15 (of 37 total)
  • You must be logged in to reply to this topic.