Support » Fixing WordPress » Update Now button inactive

  • Resolved avfadagio

    (@avfadagio)


    On one of my WordPress sites, I can’t press the Update Now button to update to the latest version. It is there but it is inactive. I’ve disabled all plugins and tried a standard theme but to no avail. In addition, I can’t save my Contact 7 contact form. The Save button is inactive. I make a change and can’t save it. If I refresh the page it asks if I am sure I want to leave without saving, but I can’t save. Seems like a pattern.

    What would cause these buttons to not be active? My other two sites work fine, all hosted by the same provider.

    It used to work. I’m only one WordPress version behind, so I know I’ve updated before.

    Thanks.

    • This topic was modified 1 month, 3 weeks ago by Steve Stern.
Viewing 15 replies - 16 through 30 (of 37 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Can you install Health Check? On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Also, its primary report may shed some light on other errors.

    I’ll recheck.

    (Sorry for the headache!)

    Health check shows only 4 recommended items. Nothing else.

    Remove unused plugins
    Remove unused themes
    Site does not use https
    Site does not use localized timezones

    Just to explain the symptom in a different way. When I move my mouse over the Save button in settings, it stays an arrow and does not change to a finger, so it can’t be clicked. On my other two sites, it, of course, changes to a finger so I can click it.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, please copy from Health Check’s Info tab using the “Copy site info to clipboard” button and paste that into a reply here.

    
    ### wp-core ###
    
    version: 5.2.4
    site_language: en
    user_language: en
    permalink: /%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/vafadagio/public_html/wordpresssoli
    wordpress_size: 138.08 MB (144785188 bytes)
    uploads_path: /home/vafadagio/public_html/wordpresssoli/wp-content/uploads
    uploads_size: 15.78 MB (16542139 bytes)
    themes_path: /home/vafadagio/public_html/wordpresssoli/wp-content/themes
    themes_size: 9.93 MB (10412807 bytes)
    plugins_path: /home/vafadagio/public_html/wordpresssoli/wp-content/plugins
    plugins_size: 31.75 MB (33291485 bytes)
    database_size: 2.39 MB (2505144 bytes)
    total_size: 197.92 MB (207536763 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Fourteen (twentyfourteen)
    version: 2.7
    author: the WordPress team
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, automatic-feed-links, post-thumbnails, menus, html5, post-formats, custom-background, featured-content, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /home/vafadagio/public_html/wordpresssoli/wp-content/themes/twentyfourteen
    
    ### wp-themes-inactive (5) ###
    
    Azera Shop: version: 1.1.17, author: ThemeIsle
    Twenty Fifteen: version: 2.5, author: the WordPress team
    Twenty Nineteen: version: 1.4, author: the WordPress team
    Twenty Seventeen: version: 2.2, author: the WordPress team
    Twenty Sixteen: version: 2.0, author: the WordPress team
    
    ### wp-plugins-active (12) ###
    
    Better Search Replace: version: 1.3.3, author: Delicious Brains
    Contact Form 7: version: 5.1.4, author: Takayuki Miyoshi
    Disable Comments: version: 1.10.2, author: Samir Shah
    Easy Updates Manager: version: 8.1.0, author: Easy Updates Manager Team
    Envato Market: version: 2.0.3, author: Envato
    Frame Buster: version: 1.1.2, author: Nicholas Z. Cardot - Dustin W. Stout - Jason T. Wiser
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    PayPal Donation: version: 1.2.9, author: Scott Paterson
    Postman SMTP: version: 1.7.2, author: Jason Hendriks
    WP-SpamShield: version: 1.9.43, author: Red Sand Media Group
    WP Staging: version: 2.6.3, author: WP-Staging
    WP Super Cache: version: 1.7.0, author: Automattic
    
    ### wp-plugins-inactive (3) ###
    
    Astounding Spam Prevention: version: 1.15, author: Will Jenkins
    Honeypot for Contact Form 7: version: 1.14.1, author: Nocean
    PHP Compatibility Checker: version: 1.5.0, author: WP Engine
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1684
    imagemagick_version: ImageMagick 6.9.4-10 Q16 x86_64 2017-11-14 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 62 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 62 GB
    	imagick::RESOURCETYPE_MEMORY: 31 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32-954.3.5.lve1.4.66.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.8 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 32M
    php_post_max_size: 32M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Tue, 15 Oct 2019 20:11:58 GMT
    	server: Apache
    	x-powered-by: PHP/7.3.8
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <http://solideogloriainstitute.org/wp-json/>; rel="https://api.w.org/", <http://solideogloriainstitute.org/>; rel=shortlink
    	content-encoding: gzip
    	vary: Accept-Encoding,Cookie,User-Agent
    	upgrade: h2,h2c
    	content-length: 6563
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.45-cll-lve
    client_version: 5.6.45
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/vafadagio/public_html/wordpresssoli/wp-content
    WP_PLUGIN_DIR: /home/vafadagio/public_html/wordpresssoli/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    max_input_time: -1

    That seems like a problem.

    Is it also like that on the working sites?

    Can you bump that to at least 300?

    If you can edit or override the system php.ini file, try max_input_time = 300

    If you cannot edit or override the system php.ini file, add php_value max_input_time 300 to your .htaccess file.

    max_input_time:-1 is that way on my other two working sites.

    I did notice that this value is true in the non working site.

    htaccess_extra_rules: true

    It is false in one that works and non-existent in the other one that works.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, might as well try that.

    Where do I change that setting?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If you can edit or override the system php.ini file, try htaccess_extra_rules = true

    If you cannot edit or override the system php.ini file, add php_value htaccess_extra_rules true to your .htaccess file.

    I found this comment doing a Google search – “WordPress performs autosaves as you edit a post. An autosave or even a publish command can be interrupted by connection problems, in which case you are left with a greyed out button, unable to save your post even as a draft!”

    Doing a little more research and found that using the Inspect option in Chrome shows the code and that there is a ‘disabled’ value after the buttons that don’t work.

    <input type=”submit” name=”submit” id=”submit” class=”button button-primary” value=”Save Changes” disabled>

    I can actually remove the ‘disabled’ and then the button is active, but once I refresh the page the ‘disabled’ value comes back.

    What is causing ‘disabled’ to be added to this code? Seems like Autosave is doing something??? And why just on some buttons?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    And it’s only on this one site?

    Are the other sites on the same exact server?

    What is the URL of one of the working sites?

    Yes, only the solideogloriainstitute.org site.

    My main site is http://www.floetermusic.com which works. This is located in the root of the godaddy hosting area. http://www.software-experience.com (which also works) and the soli site are in sub folders of the root. So all on the same server.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    It looks like the three are on different servers, or at least their name servers are different:

    https://www.whatsmydns.net/#NS/solideogloriainstitute.org
    https://www.whatsmydns.net/#NS/floetermusic.com
    https://www.whatsmydns.net/#NS/software-experience.com

    I’d wonder if something is misconfigured server-side on the site with the problem.

    Can you ask them to move you to a new server?

Viewing 15 replies - 16 through 30 (of 37 total)
  • You must be logged in to reply to this topic.