• Resolved Steve Sears

    (@flsocialist)


    Seems that the lastest update left me with a fatal error. I had to remove the plugin (social warfare) It’s the free one that fails (and fails to install now) now the paid. The failure tood the whole site down

    Warning: require_once(/home1/steve/public_html/voicesoflabor.com/wp-content/plugins/social-warfare/functions/Social_Warfare.php): failed to open stream: No such file or directory in /home1/steve/public_html/voicesoflabor.com/wp-content/plugins/social-warfare/social-warfare.php on line 28

    Steve

Viewing 15 replies - 1 through 15 (of 44 total)
  • +1 Same issue on production multisite instance. On another single site instance we’re seeing mangled styles but no “Fatal error”. Updated pro and regular versions to 3.0.1, no change. Removed Pro plugin, no change.

    Had to disable plugin(s) for both sites.

    Please take a look at this as soon as possible.

    PHP Fatal error: Call to a member function parse_api_response() on null in /wp-content/plugins/social-warfare/functions/utilities/share-count-function.php on line 106

    PHP Fatal error: require_once(): Failed opening required ‘/wp-content/plugins/social-warfare/functions/Social_Warfare.php’ (include_path=’.:/usr/share/php’) in /wp-content/plugins/social-warfare/social-warfare.php on line 28

    Plugin Contributor Christine

    (@cdegraff1)

    We are so sorry for the trouble! Please remove both plugins (your settings won’t be lost), then reinstall version 3.0.1, which is now available. If you are unable to access your admin, you may have to use FTP. You can download the core plugin directly inside the WordPress plugin directory, and the Pro plugin can be downloaded via this link: https://warfareplugins.com/updates/social-warfare-pro/social-warfare-pro.zip.

    This tutorial (https://warfareplugins.com/support/updating-social-warfare-social-warfare-pro/) explains exactly how you can safely update your plugins manually. (You can skip straight to 1min and 57sec into the video.)

    That should resolve the issue but please submit a support ticket to info@warefareplugins.com if you have any additional problems.

    Thanks,
    Christine

    No dice. On my staging environment (multisite) I updated both plugins to v3.0.1 and we’re still seeing a fatal error on any page calling the “social_warfare” function.

    PHP Fatal error: Call to a member function parse_api_response() on null in /wp-content/plugins/social-warfare/functions/utilities/share-count-function.php on line 106

    Keep in mind many hosts auto-update WordPress plugins, so sending an email telling people not to update just one version, at the same time of the release no less, is not at all helpful or preemptive.

    Good luck!

    I got a similar error.

    And I have to agree with @firebrandllc. Sending an email is not the way to go. I have auto-updating, so an email was no help in telling me that my site was down due to a bad upgrade.

    • This reply was modified 4 years, 3 months ago by bobsled.

    Same issue as firebrandllc exactly.

    PHP Fatal error: Call to a member function parse_api_response() on null in /wp-content/plugins/social-warfare/functions/utilities/share-count-function.php on line 106

    I’ve had to deactivate the core and the pro addon to get the site backup. This is a critical error for my client considering they just started running a national month-long promotional campaign, and now this plugin decides to be broken.

    Waiting for that hotfix!

    Same problem here.
    Update, version 3.0.1 is what broke my site, deleted the plugin and had no site, now my hosting provider has to restore a previous version. Tried re-installing the old version and that didn’t work either. This is huge problem for my client’s business. So incredibly disappointing.
    Support is silent I see.

    The same problem 500 HTTP error

    500 error here as well, due to automatic update. Had to deactivate this plugin on all my sites via File Manager since I couldn’t get into WordPress.

    Deactivation didn’t work for me. I tried that first. It completely broke my site and we are trying to conduct business. Nothing works, no woocommerce, nothing. It is being restored from a backup.

    Cannot believe this happened and they are doing nothing to address it.

    Hello, with version 3.0.2 no longer HTTP 500 error, but now the images of the entries is not displayed, everything is blank.

    I have cleaned the browser and server cache but it remains the same.

    Updated to V3.0.2 but it seems to have broken all javascript on the site. Menu doesn’t respond, pages don’t load (white screen).

    Same problems as above. Update crashed site 500 error. Deleted to get site back. Tried uploading the other versions but no go.

    Similar issues for me on 3.0.2.. site broken on any page with the plugin.

    • This reply was modified 4 years, 3 months ago by ande1352.

    Hi, all! I just wanted to let everyone know we’re working nonstop to address bugs as quickly as they’re reported.

    Regarding @firebrandllc, @firebrandllc, @kneesocks, @christifultz sentiment on auto-updating, we really hope to find a way to prevent this. It’s a challenging issue because both Social Warfare and Social Warfare – Pro are so dependent on one another, that a change in one inevitably affects the other. We will continue to find a way to make it so that the symbiotic relationship between the two can be less problematic when updated separately.

    Regarding @chickenmama’s “support is silent,” I can certainly understand why it might look that way if this is the only place you’re looking for support. Our small team of 5 has been working nonstop answering official support tickets (which must be submitted through our website) and responding to Twitter and Facebook comments/questions/messages/replies. Our developers have also pushed out several small updates this morning to address bugs as they’ve come up. If you ever need assistance in the future, it’s always best to go through the official support request form on our site.

    If anyone else wants to get a previous version before the update today to roll back, our support team can send you the previous files to install until we’re able to work out all the current bugs in 3.0+.

    Hoo boy. Still broken even after updating both plugins to 3.0.2. Same error as before.

    PHP Fatal error: Call to a member function parse_api_response() on null in /wp-content/plugins/social-warfare/functions/utilities/share-count-function.php on line 106

    Starting to feel bad now, looks like this release was not at all ready for production. Let me know if you guys need any help.

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Update’ is closed to new replies.