Support » Plugin: Print-O-Matic » "Undefined" result

  • Resolved Don Grafues

    (@sprarts1)


    I have tried everything I could think of but with no success. The page I am working on is http://cta.sprarts.org/artist-entry/. I tried title and no title, target=”.single-image”, =”single-image”,=”image”, etc., etc. All I get is a page with “undefined”. I copied the necessary code to my stylesheet. This plug-in seems to be my best set to be able to print the image but I desperately need your help. I am using FoxFire for browser and Windows 7 (if any of that matters). Many thanks.

    http://wordpress.org/extend/plugins/print-o-matic/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I could not wait so found another (inadequate but it works) solution.

    Plugin Author Baden

    (@baden03)

    Sorry for the delay… let us know if you want another go.

    I figured out how to get Print-o-matic to work so I am using it. Only issue I have now is that different browsers react differently. I use Foxfire and the image prints ok but slightly reduced in size with a larger than necessary top and left margin. My IE (9) is the same, Chrome prints on two pages. Another user gets two pages on IE but I don’t know the version. Picky stuff, I know but I would like the print to be as near perfect as possible across all browsers. Many of the site users are not computer literate. I am using Print-o-matic on two pages, http://cta.sprarts.org/artist-entry and http://cta.sprarts.org/waiver/.

    I’m not sure if there is anything you can do but I will turn “no right click” off so you can look at code.

    Thanks,
    Don

    Plugin Author Baden

    (@baden03)

    Hey Don,

    You might try adding the theme’s css (or adding your own custom css that defines your body tag) in the print-o-matic options page.

    Sounds like each browser has default css, and all you need to do is define what css should be used.

    Let us know if that helps!

    WebNut

    (@healthy-lawn-dude)

    I have the same problem
    Blank sheet comes up with ‘undefined’ on the top right hand corner.
    I have Gone over everything in settings.

    Plugin Author Baden

    (@baden03)

    Link Please

    WebNut

    (@healthy-lawn-dude)

    Here is link, I have it set up <center> [print-me] </center>
    same result ‘undefined’ when center coding was not there.
    http://myhealthylawn.ca/
    thank you

    Plugin Author Baden

    (@baden03)

    Lawn Dude,

    You need to define a target, such as the div with the id of content like so:

    <center> [print-me target="#content"] </center>

    Can you dig it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘"Undefined" result’ is closed to new replies.