• Hey,

    I am very satisfied with this great plugin. It took a while to install, in particular the authentication codes was not easy but it works fantastic.
    The only thing that I’m struggling with now, is the slideshow.
    I don’t get it working in any way that it represents the True Size! I have already tried ‘full’ in de code, but he continues to see a reduced and even a limited view.

    I use the plugin to display newspaper articles.

    In de past I’ve tried to made some pages in html.
    It doesn’t really look representative, but the true size in no problem in you click on the pictures…
    http://www.marebos.nl/kranten/artikelpagina-9-1969-78.html

    Could you help me out? Thanks in advanced,

    Marc

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter Marc

    (@marebos)

    Hi,

    I had forgotten something, how do I get these albums responsive for phone and tablet?

    Thank you

    Plugin Author Sayontan

    (@sayontan)

    At present I am seeing nothing on your site, which is because you are using caching with Google Photos. Please note that Google Photos cannot be used with caching plugins; Google Photos URLs are “short-lived” and expire after around 30 minutes.

    Also note that Google Photos have no provision for a “full” size. They support really large images, so you can put in a size of 10000, and Google will automatically find the largest image if it is smaller than 10000px.

    I had forgotten something, how do I get these albums responsive for phone and tablet?

    Apart from the square thumbnail layouts where you are pre-defining the number of columns, Photonic is 100% responsive by default. If you are not getting responsive behaviour, once you have disabled caching on this particular page let me know and I will take a look.

    Thread Starter Marc

    (@marebos)

    Hey Sayontan,

    Thank you for your quick response!

    I removed the pages from the caching, they are visible again.

    What I am trying to achieve is that visitors can read the newspaper clippings in true size …

    As an example my own ugly self-produced html pages
    http://www.marebos.nl/kranten/artikelpagina-9-1969-78.html

    But you can read the articles here normally when clicking on them, with the magnifying glass and space is created with the scrollbars to the right and bottom.

    I really hope you can help me, because I have tried so many plugins already.
    Don’t wanna go back to html pages.

    Regards,

    Marc

    • This reply was modified 1 year, 5 months ago by Marc.
    Thread Starter Marc

    (@marebos)

    Have just opened a page on my phone and see here that, in the slideshow, I can enlarge the photos (clippings) by spreading with 2 fingers on the screen.
    Only notice that the tumbnails are too big and my screen is flickering.

    Plugin Author Sayontan

    (@sayontan)

    I am not seeing any flickering effect on your site on any of my mobile devices (I checked on an iPhone 7, iPhone 8, iPhone X and Pixel 3).

    The large thumbnails are because of your setting, where you have defined your “Thumbnail size” to be 700.

    Here is what you can try:

    1. Use something like the “Random Justified Grid” layout
    2. And use a “Tile size” of 700 (not Thumbnail size, but Tile size, as the Random Justified Grid uses the tile size)

    The justified grid layout is fully responsive, and your thumbnails will be set to the correct sizes automatically.

    Thread Starter Marc

    (@marebos)

    Hello Sayotan,

    Sorry, your Justified Grid, didn’t make any difference.

    I spent a lot of hours again solving my problem.
    Even tried things with shortcode columns, etc, back to basics…

    Only my ugly self-made pages meet my expectations.
    And I’d rather would clean (delete) them up, it just doesn’t look nice…

    I have come the furthest with this plugin!
    Tried really many over the past months.

    But I also found the problem in my search!
    The Lightbox display is just too small, maximum dimension is 1054 … x ….

    So a photo (clipping) larger than 1054 will not be displayed in the (true) correct size.

    Is there a possibility to change (overrule) the code (CSS) for the Lightbox for Google Photo’s to:

    https://mdbootstrap.com/support/general/lightbox-with-different-image-sizes-and-formats/

    Thank you,

    Marc

    Plugin Author Sayontan

    (@sayontan)

    The Lightbox display is just too small, maximum dimension is 1054 … x ….

    So a photo (clipping) larger than 1054 will not be displayed in the (true) correct size.

    Sorry, that is not correct. Your “Main image size” is set to 1600px, so that is the largest you will get in the lightbox, not 1054px. Note that a lightbox will always fit an image to your screen if it is larger than the screen. I am viewing your site on a desktop that is 2160px wide, so I am seeing the full image wherever possible. E.g. your third image, “Broodexport naar Duitsland” is 1109px tall, so I see it fully in my screen.

    As you have observed, it is always possible to pinch-and-zoom within the screen – it will get you to the maximum image possible. E.g. if you know that your largest image is 5000px tall, you can set the “Main image size” to 5000px. Then, an image larger than 5000px will be scaled down to 5000px, and an image smaller than 5000px will be left at its original size. E.g. your current setting is 1600px, but the “Broodexport naar Duitsland” image is 1109px tall, so you are getting an image that is 1109px in size.

    Sorry, your Justified Grid, didn’t make any difference.

    Maybe I am unable to understand what you are trying to do. The Justified Grid only applies to the main page – it will show you smaller thumbnails, which you can click to show the lightbox.

    Is there a possibility to change (overrule) the code (CSS) for the Lightbox for Google Photo’s to:

    There is no point. Photonic’s lightboxes already get you the correct size from the shortcode. As I have mentioned in my first post, if you set the “Main image size” to a larger number, that will get you the correct size. Remember that you have to pinch-and-zoom to expand the images. Maybe you don’t want to use a lightbox at all?

    Thread Starter Marc

    (@marebos)

    Hello Sayotan,

    Remember that you have to pinch-and-zoom to expand the images.

    I can’t pinch-and-zoom to expand clippings on my desktop, only on mobile. But that causes flickering as a mentioned earlier (on my Huawei P30)

    Maybe you don’t want to use a lightbox at all?

    Now we are getting somewhere 🙂
    How can I send a “click” on a clipping to a browser? Instead to the Lightbox?

    If possible, this would end our discussion…

    Thank you,

    Marc

    Plugin Author Sayontan

    (@sayontan)

    I can’t pinch-and-zoom to expand clippings on my desktop, only on mobile.

    If you use the LightGallery lightbox (selected under Photonic → Settings → Generic Options → Generic Settings → Inbuilt Lightbox libraries), that offers an explicit “zoom” option within the lightbox (enabled from Photonic → Settings → Lightboxes → LightGallery → Add Zoom). The Fancybox3 lightbox also offers a zoom option.

    How can I send a “click” on a clipping to a browser? Instead to the Lightbox?

    If possible, this would end our discussion…

    Again, under Photonic → Settings → Generic Options → Generic Settings → Inbuilt Lightbox libraries, you can select “None” – that will ensure that there is no lightbox being used.

    Thread Starter Marc

    (@marebos)

    Hello Sayotan,

    I had hoped we were finished and had solved this issue…

    If I set the settings as you described (None), the clippings go to: https://photos.google.com/
    You can try it for yourself with this page:
    https://marebos.nl/kranten/artikelpagina-5-1965/

    I just want to open any clipping on this page in a browser. that’s all.

    Thank you

    • This reply was modified 1 year, 5 months ago by Marc.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘True Size’ is closed to new replies.