Support » Plugin: List Custom Taxonomy Widget » Strict Standards warnings

  • Resolved davemac

    (@davemac)


    With debug turned on and using PHP 5.4 I am getting a strict standards warning:

    Strict Standards: Declaration of lctwidget_Taxonomy_Dropdown_Walker::start_el() should be compatible with Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in wp-content/plugins/list-custom-taxonomy-widget/list-custom-taxonomy-widget.php on line 300

    http://wordpress.org/plugins/list-custom-taxonomy-widget/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Nick Halsey

    (@celloexpressions)

    Thanks, there was another post about this but it seems to have been deleted due to a forum hiccup. I’ll fix it in the next update.

    Plugin Author Nick Halsey

    (@celloexpressions)

    (also, this is just a warning that was added in 3.6)

    davemac

    (@davemac)

    Just bumping that I am still receiving these Strict Standards Warnings in latest version, thanks.

    Plugin Author Nick Halsey

    (@celloexpressions)

    Thanks for the bump, I forgot about the current status of this plugin and haven’t pushed any updates since this issue came up. I fixed this issue about 5 months ago in the dev version but had been having a lot of long-term problems with the dropdown display type linking to terms correctly. I’ll schedule this plugin for a big cleanup effort and try to push the update, including this fix, in the next few weeks.

    davemac

    (@davemac)

    Really appreciate that, thanks Nick

    Any word on a fix for this? I am seeing this same error under WordPress 3.9 using version 3.3 of the List Custom Taxonomy Widget plugin and with debug enabled.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Strict Standards warnings’ is closed to new replies.