Support » Plugin: Rate my Post - WP Post Rating » some minor bugs

  • Resolved rdrit

    (@rdrit)


    Hello,

    First of all thank you for this great plugin.

    I have two problems with it.

    The first is the administration, I can not register settings, I have this error systematically: Error saving settings! Try clearing all caches, including your browser cache!

    I obviously try to clean the cache and change browser the problem persists. I am thinking of a bug with the use of memcached.

    The second bug is PHP Notice error that goes back into Query monitor:

    Notice	Undefined index: socialShare	1	
    +
    wp-content/plugins/rate-my-post/admin/partials/rate-my-post-menu-options.php:298
    Plugin: rate-my-post
    Notice	Undefined index: archivePages	1	
    +
    wp-content/plugins/rate-my-post/admin/partials/rate-my-post-menu-options.php:403
    Plugin: rate-my-post
    Notice	Undefined index: votingPriv	1	
    +
    wp-content/plugins/rate-my-post/admin/partials/rate-my-post-menu-security.php:39
    Plugin: rate-my-post
    Notice	Undefined index: votingPriv	1	
    +
    wp-content/plugins/rate-my-post/admin/partials/rate-my-post-menu-security.php:40
    Plugin: rate-my-post
    Notice	Undefined index: archivePages	511	
    +
    wp-content/plugins/rate-my-post/public/class-rate-my-post-public.php:464
    Plugin: rate-my-post

    Best regards

    Romain

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Blaz K.

    (@blazk)

    Hi Romain,

    thanks for reporting the issues. These two errors are connected. I suspect that something went wrong on plugin activation or update and not all default options are stored in the database. If you just installed the plugin I recommend deleting and reinstalling it. Make sure to enable “Delete all plugin data on uninstall” as the options otherwise won’t get rebuilt. Note that this will also delete all you ratings.

    If this happened after update please let me know from which version to which version you upgraded for debugging purposes. If you are comfortable with ftp, there is a quick fix. Open rate-my-post/rate-my-post.php and on line 27 change:

    
    define( 'RATE_MY_POST_VERSION', '2.5.0' );
    

    to

    
    define( 'RATE_MY_POST_VERSION', '2.5.0.1' );
    

    This will force the plugin to rebuild the options. Then just refresh the page and there should be no errors 🙂 If you are not comfortable with ftp, let me know and we’ll try to find a different solution 🙂

    Regards,
    Blaz

    Hello,

    Thank you your tip allowed me to solve the type error in PHP.

    It was still impossible to save the options in the administration interface.

    Do you have an idea ? I tried to disable memcached the problem remains the same.

    Romain

    Plugin Author Blaz K.

    (@blazk)

    The save error in 90% of cases appears due to browser cache after the update – the old javascript is cached in browser and thus not all data is passed to the server. Did you clear your browser cache? Also clear all other caches, including the CDN cache if you are using one.

    Plugin Author Blaz K.

    (@blazk)

    @rdrit,

    did you manage to solve this? It would be also very useful if you can tell from which version you upgraded for debugging purposes 🙂

    Blaz

    Hello,
    Unfortunately I have not managed to solve the problem.
    When I need to modify options I do it directly from the database.
    Romain

    Plugin Author Blaz K.

    (@blazk)

    @rdrit it would be awesome if you can join me on Slack and we try to debug this – I’m very curious what happened there 🙂 Here is the invite:

    https://join.slack.com/t/ratemypost/shared_invite/enQtNTE0MDcyNjg5NTM4LTljNjRjYzRjMGFiOWRhYmM0MWZkYTlmZDQ1MzIyZjM3YzU0N2U1MWRlODM5MjczNmFhZjU1ZDllZTgxOGE3Y2M

    Hi,

    Version 2.6.0 fixes my backup problem 🙂

    Good job.

    Thank you for this very good plugin

    Sorry I could not come on Slack, I have a lot of work on hand right now

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘some minor bugs’ is closed to new replies.