• I am having an issue with accessing the settings page.
    The message displayed is: MonsterInsights has detected that it’s files are being blocked.

    However in the network trace I see that the plugin is trying to load its CSS and jquery files from a wrong location.
    It tried to load the files from the path of where a different website is running (on the same server)
    Any ideas on how to fix this ?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author chriscct7

    (@chriscct7)

    Hi there,
    MonsterInsights uses the built in WordPress file/url functions. If you’re having this issue, what it means is your host has a misconfiguration in the PHP setup (likely the default include path) of your server and you’ll want to contact them so they can fix that for your account

    -Chris

    I thought I had solved the issue by upgrading to plugin version 6.2.6 (from version 6.2.4).
    After upgrading both website on the same server the plugin on the website which was functioning OK before the upgrade is not working anymore and the plugin on the website which was not working is now working.

    Addition: In the beginning one site was a copy of the other.
    In the database and the filesystem NO references to the other site can be found. (plain text search only)

    • This reply was modified 1 year, 6 months ago by  mvanderkruk.
    • This reply was modified 1 year, 6 months ago by  mvanderkruk.
    • This reply was modified 1 year, 6 months ago by  mvanderkruk.

    Having this same issue, anyway to fix to be more generic? No other plugins seem to have this issue. Thanks,

    -Garrett

    Plugin Author chriscct7

    (@chriscct7)

    There’s no way for us to be more generic with how we are requesting files. We are simply using plugin_dir_path( __FILE__ ). ‘{file}’

    As a note, we haven’t changed how we’ve referenced files ever. If it’s working now, likely your host fixed something on your server.

    -Chris

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Settings page not working’ is closed to new replies.