Support » Plugin: Clef Two-Factor Authentication » setcookie() parameter error on php 7

  • Resolved the.mnbvcx

    (@themnbvcx-1)


    I just switched my server from php 5.6.21 to php 7.0.6 for a treat – but now I keep getting an error message in the WP dashboard:

    Warning: setcookie() expects parameter 3 to be integer, float given in /home/www/wp-content/plugins/wpclef/includes/lib/wp-session/class-wp-session.php on line 130

    Clef login works apparently, but still this error looks a bit annoying…

    https://wordpress.org/plugins/wpclef/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor inthylight

    (@inthylight)

    @the.mnbvcx

    Thank you for reporting this issue. I have verified it and submitted a fix (beta).

    The change for the fix is very small and thus should be safe to run; if you would like to test drive the beta (and loose the error message), delete the currently installed plugin via the Plugins menu, then download this beta .zip and install via the Plugins -> Add New -> Upload option (near the top).

    Please let me know if you run into any issues.

    Laurence,
    thx for the quick fix – applied it and indeed the error msg is gone.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘setcookie() parameter error on php 7’ is closed to new replies.