Support » Plugin: PowerPress Podcasting plugin by Blubrry » RSS description field charset problem

  • Resolved emaster7

    (@emaster7)


    Hi there

    Thank you for great plugin, i’m using it for my podcast site by-emaster.com.

    Recently I’ve found strange problem with podcast RSS (http://by-emaster.com/feed/podcast/). Description field for each podcast entry appears in wrong charset. My podcast descriptions are non-latin (russian), so my description appears garbled. It’s strange because podcast title is ok and also content-encoded also shows right description.

    Please advise how it can be fixed.

    Thank you,
    Eugene

    https://wordpress.org/plugins/powerpress/

Viewing 8 replies - 1 through 8 (of 8 total)
  • marcinhinz

    (@marcinhinz)

    I think I have similar problem on http://jakoszczedzacpieniadze.pl/feed/podcast/
    Polish signs are wrong in <itunes:summary> section.
    What can cause this problem?

    Plugin Author Angelo Mandato

    (@amandato)

    Are you both using the latest version of PowerPress?

    The latest version we made one change, but it only impacted the itunes:summary and itunes:subtitle fields. it took into account if the database is using utf8mb4, that it would not convert that to utf8.

    Are your databases and tables using utf8 or utf8mb4?

    marcinhinz

    (@marcinhinz)

    In my case you were probably right. 🙂
    How can I refresh/regenerate feed now? We made changes 24h ago and iTunes have still wrong charset.

    Plugin Author Angelo Mandato

    (@amandato)

    emaster7 and marcinhinz, Just following up, I haven’t seen an issue since you updated. Perhaps it was just cached in your browser?

    Charset was fixed and feed updated automaticly. Everything works well. Thanks 🙂

    Plugin Author Angelo Mandato

    (@amandato)

    marcinhinz, Glad to hear you are no longer having problems. I just did a quick test and confirmed your feed is working perfectly.

    emaster7, I just tested your feed as well and it is not having any problems either.

    Angelo, Marinhinz – thank you very much, problem is gone and all work ok.

    And happy new year!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘RSS description field charset problem’ is closed to new replies.