Support » Plugin: Autoclear Autoptimize Cache » Reloads page constantly

  • Resolved DeveloperWil

    (@developerwil)


    Have had to disable the plugin as it seems to constantly refresh pages on my site that are using wow.js.
    Perhaps there’s some sort of conflict between the two?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author John Teague

    (@jteague)

    For wow.js, there are a lot of reports of conflicts with other plugins as well. I’m not sure how to test against it, but the latest release of autoptimize plugin now triggers a cache deletion of w3 total cache and wp supercache plugin cache to prevent conflicts. and it appears to solve this issue.

    Hi, I see that there’s no way to disable w3 total cache deletion trigger? Can you add a setting for this, or is it mandatory?

    Thank you!

    Plugin Author John Teague

    (@jteague)

    Let me take a look at that possibility. That function is set within Autoptimize itself, but there may be a way past it. I’ve been thinking about incorporating our own cache deletion functionality. I’ll look into it and then report back. Thank you for your patience and help with diagnosing the problem. It’s one of those edge cases that’s been harder to get at the cause. But, I’ll stay on it.

    Confirmed that my pages with wow.js no longer auto-reload when your plugin is activated. THanks for the update!

    Wil.

    Plugin Author John Teague

    (@jteague)

    Awesome. So glad it’s resolved. Thank you for your help and for using the plugin.

    Now I’m having this problem on https://batgap.com. I’ve had Autoptimize installed for a month or two and installed Autoclear Autoptimize Cache in the past day or two. This morning I discovered and a site visitor reported that some pages in the site, but not all, were reloading repeatedly. I fiddled around deactivating and reactivating the plugins, and I cleared the cache. Now I’m not getting the problem but my wife still is in Firefox on a Mac but not in Chrome. I’ve cleared her browser cache a couple of times. Any suggestions?

    Plugin Author John Teague

    (@jteague)

    Can you let me know if you have any other caching plugins installed, such as WP Supercache or WE Total Cache, etc. And who and what hosting package your using. This is usually caused by having those types of plugins containing cached versions of the site after Autoptimize has been cleared. Normally that clears all of your local site cache files, not just Autoptimize.

    If you use a host that uses their own server side caching methods it can also cause this. The extra info may help me pin down exactly why that’s happening. Also, I’ll finally have an updated version of the plugin out by the weekend, and it will save the settings as soon as it’s installed, which should solve this.

    Apologies for the issue. Thank you for reporting it.

    cammyjjj

    (@cammyjjj)

    I have the same problem with my webpage. I also run autooptimize and w3 total cache, but for a long time. I’ve tried to delete the cache. I’ve tried to deactivate both, but no changes.

    It started a week ago when I was playing around with some pages, landingpages and pagebuilders.

    DeveloperWil

    (@developerwil)

    Yes, the issue has come back on my site again last week. Disabled plugin temporarily.

    cammyjjj

    (@cammyjjj)

    @developerwil I finally found out what my problem is. The reload for me goes like this ?cn-reloaded=1

    It’s a problem with the plugin Cookie Notice. Instead I use GDPR Cookie Consent Banner. Solved my problem.

    DeveloperWil

    (@developerwil)

    @cammyjjj Thanks for the update. I don’t use that particular plugin, so I suspect it’s something to do with caching. Gr8 that you have your issue sorted!

    Plugin Author John Teague

    (@jteague)

    Just when I thought I’d figured this out. It seems like there are a couple of situations where this occurs, but I appreciate the additional info.

    Hello John! Sorry to bring this back to life but I am also having this issue.

    I am hosted at Kinsta which uses it’s own cache.

    Had to disable the plugin for a while.

    Also I am using WebP Express, which I am not sure is useful info.

    Plugin Author John Teague

    (@jteague)

    Thank you fir the report. It appears we’ve finally figured out what causes this, which resides around certain conditions when object caching is set to override the max age setting. This can happen with certain web hosts and CDNs. I’m finishing a fix and testing it.

    In the meantime disabling our plugin, completely emptying object cache from plugins or third party services and purging CDNs and the activating and setting the max allowable cache in our plugins settings page should resolve this. If that interim solution fails, disabling it and waiting on the update (about 10 to 14 as we wait for WordPress core update to land) should do the trick. Please let me know.

    Thank you again for your patience. I understand how frustrating issues like this can be, especially when they only appear when under certain conditions .

    andreas1992

    (@andreas1992)

    Hey John, do you have any news?

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.