Support » Plugin: Jetpack by WordPress.com » Related Posts with Gutenberg

  • Resolved billbennett

    (@billbennett)


    This message is on the reading settings “The following settings will impact all related posts on your site, except for those you created via the block editor:”

    As expected some posts now show related posts, others don’t. Other than not using the block editor, is there a way to make them return?

    I suspect this may not be Twenty-Nineteen theme specific… but It’s only emerged on my staging site that uses the new theme. Related posts work fine on my production site with another theme.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @billbennett,

    Just to check I’ve understood correctly — do you mean you want to display related posts at the bottom of all posts, regardless of whether they were created using the block editor?

    Related posts work fine on my production site with another theme.

    What is the name of the theme where related posts aren’t working? Or were you referring to the issue occurring on Twenty Nineteen?

    It’s more that I want the option of showing related posts at the bottom. If that means ALL posts it’s a lot better than only those composed with the old editor.

    Yes, it’s a problem with twenty nineteen, my current production theme supports it fine, but I’ve got a twenty nineteen development site ready t go after a handful of minor fixes including this one.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    If you want Related Posts to appear under _every_ post, simply select “Show related content after posts” at Jetpack > Settings > Traffic in your site’s Dashboard: https://jetpack.com/support/related-posts/

    If that doesn’t work, would you please give us a link to one post where Related Posts appear, and one post where they do not?

    Yes. It is switched on in Jetpack. Keep in mind this is a development site, so the link won’t work for long, but I won’t touch it for a week or two (unless we find a fix).

    On this page related posts shows as expected:

    https://billnz.mystagingwebsite.com/mobile-world-congress-5g-folding-phones-and-huawei-politics/

    On this page it doesn’t show:

    https://billnz.mystagingwebsite.com/chorus-10gbps/

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @billbennett,

    Thanks for the links, they were a great help.

    I’ve had a closer look and while related posts aren’t being displayed, my browser inspector shows a “Related” header in the source code and when I ran a test from my side, there is a list of related posts. So in short, Jetpack is finding them but they are not being output on the site.

    It would be great if you could try a couple of things for us:

    1. Please try deactivating the Fast Velocity Minify plugin
    2. If that doesn’t make a difference, disable all plugins except Akismet, Gutenberg and Jetpack

    Let us know how you get on and we can go from there.

    • This reply was modified 2 months, 2 weeks ago by  Gemma Evans.

    Removing the Fast Velocity Minify plug-in fixes the problem. I’d like to be able to run the plug-in if possible, so it would be good to get to the bottom of the problem.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi there,

    Fast Velocity Minify plugin is one of the caching plugins that is known to interfere with Jetpack/WordPress.com’s caching system. It could even potentially crash sites. So, it is recommended not to use both plugins.

    However, there are settings that you can use to utilize them both simultaneously:

    https://d.pr/free/i/dzgb9K

    Any other settings will for sure cause issues.

    For more information on incompatible plugins: https://en.support.wordpress.com/incompatible-plugins/#caching-plugins

    Hope this helps.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.