Support » Plugin: Quick Paypal Payments » Problem with Email Confirmation since Update

  • Resolved Abigailm

    (@abigailm)


    I am suddenly seeing changed formatting of email confirmation for about a week now, and I think it probably is a result of this change reported in the changelog for version 5.6:

    > Notification emails now show total to pay

    Here is the problem — we do not use the form to sell items that related to quantities. It is simply a way for users to pay online from invoices that we send them — so it is a simple form with fields to enter their invoice number, amount of payment, and personal contact information.

    In the past we would get emails formatted like this:

    Order Details:
    Invoice #: 1234

    Quantity: 1

    Enter Amount Paid: $100.00

    The “Quantity” field was irrelevant and unnecessary, but wasn’t confusing.

    But now here is what we are seeing:

    Order Details:
    Invoice #: 1235

    Quantity: 1 @ $100 each

    Total: $0.00

    So this is very confusing, because even though the person has paid the full amount (example: $100) – we get an email that says “Total: $0.00”. Also, I do not know what users are seeing in confirmation mails — so far, no complaints, but if the user confirmation is the same as what we are receiving, then it also going to cause confusion.

    So basically — we’d like to get rid of display of the “Quantity” field altogether — as it is not a field included within our form—- but if that can’t be modified, then at least the “Total” should be correct. If it is “Quantity: 1 @ $100 each” then it should also display, “Total: $100.00”)

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author aerin

    (@aerin)

    Not sure why the total is showing as zero though, it worked on all the test I did.

    The quantity defaults to one. If you leave it out PayPal will reject the payment.

    So all the confirmation email does is show the data sent to PayPal.

    I can probably work on a filter that hides the quantity if equal to one.

    The reason for the new format is because many users do use the quantity and the total was incorrect (it didn’t include the handing charge).

    If you can contact me using the emails address on the plugin settings page I will send you an update to test.

    Plugin Author aerin

    (@aerin)

    Can you please install this update and test:

    https://quick-plugins.com/quick-paypal-payments/qpp-update/

    @aerin, I am sorry but I installed that update and it made things worse. Now the amount paid is not showing at all on the email.

    So, for example, tonight a user made a payment for $200.

    Here is what the email confirmation shows:

    Order Details:

    Quantity: 1

    Total: $0.00

    At least before there was one line showing cost; now the payment is simply shown as -0-.

    The “Total” really needs to match the amount paid.

    • This reply was modified 10 months, 1 week ago by  Abigailm.
    Plugin Author aerin

    (@aerin)

    I need to see the site to find out what is happening.

    I’ve tested the update again and it all works so there may be an issue with your settings.

    The website is https://ddai.link/ — you’ll see the form on the home page.

    It has one field where users enter the amount they are paying. No products or preselected amounts; it is an “Amount” field in the form settings with none of the boxes checked.

    Plugin Author aerin

    (@aerin)

    Can you try the the form on this page: http://testblog.co.uk/paypal/

    You should see the correct total on the PayPal payment page and the confirmation email you receive.

    What do you see on YOUR confirmation email? (I’ve just sent you a test from your link with the amount “200”- my email is similar enough to username here that you should recognize it).

    I am not having a problem with PayPal — and I don’t know whether the customer autoresponder email, which uses the shortcode [fullamount] – is showing a problem. I haven’t received complaints from users, but they would be receiving both a confirmation from our site and from PayPal, so perhaps are not reading the confirmation from our site. (There does not seem to be a feature to allow me to add a cc or bcc to the customer auto-responder, so difficult to test as it only sends an email after payment).

    However, the problem I am reporting is with the confirmation email sent to the site owner – under “Send Options” “Confirmation Message” (“Send yourself a copy of the payment details”) So that is where I am no receiving emails that say -0- and the only way to find out what the actual payment amount was is to login to the site and view the log of completed payments. (Or rely on the PayPal confirmation emails or records)

    I did receive the autoresponder customer email from you, and it correctly shows amount — so if you are also using the [fullamount] shortcode that probably means that part is working. But again, my question is about the confirmation email that goes to the web site owner or to whoever is designated in the “Send Options” settings.

    Plugin Author aerin

    (@aerin)

    This is the email I received:

    Order Details:
    Payment for: Test Payment
    Quantity: 1
    Total: £220

    Which is the correct amount (£200 + £10 + 5%)

    One difference with your test form and my set up is that your form adds a handling charge. So the “total” doesn’t equal the amount entered. Instead, if the amount paid is X, the Total is always X+10+(.05X)

    My form has nothing added; so “amount paid” will always equal “total”.

    Since I am seeing 0 in the Total field — I’m wondering if there is could be a problem somewhere along the line with the math. (For example, the amount being multiplied by 0 because I have no value entered in as a percentage based handling amount).

    Plugin Author aerin

    (@aerin)

    I’ve removed the handling charge and got this email:

    Order Details:
    Payment for: Test Payment
    Quantity: 1
    Total: £200

    The maths isn’t the problem as the handing charge is calculated independently of the amount. All I do is add the two amounts together at the end.

    Plugin Author aerin

    (@aerin)

    I’ve made some minor adjustments to the plugin. Can you test this version:

    https://quick-plugins.com/quick-paypal-payments/qpp-update/

    Thanks — I have tested and it looks like everything is working fine now.

    Plugin Author aerin

    (@aerin)

    Great, I’ll upload the update.

    As an aside, I didn’t change the code that calculated the total. The change was to remove some redundant code.

    When I uploaded the new version I also reviewed and re-saved all settings after activation, before doing further testing. I don’t remember doing that the last time around – so it’s possible that was a step that needed to be completed along the way.

    Abigailm

    (@abigailm)

    Bad news – I’m seeing the error crop up again — so email confirmations are still coming in looking like this:

    Order Details:
    Enter Invoice # or Description: webhosting

    Quantity: 1

    Purpose of Payment: Web Hosting

    Total: $0

    (This is for a payment amount that was actually $114).

    However, I do have more info for debugging.

    In my settings, under Autoresponder, I have the settings to Enable Auto Responder After Payment. So an email is sent only after payment completes.

    However, when testing above, I temporarily changed the option to “After submission to PayPal” rather than “After payment” so that I wouldn’t have to run an actual payment through PayPal in order to test. When I did that, the “Order Details” showed the correct total.

    Since it is now showing the incorrect total on real transactions with the “After payment” option enabled, I am assuming that the problem in the total field is somehow connected to the IPN response.

    All completed payments are showing correctly as “Complete” in the QPP payments log.

    However, I do know that on my system there is something amiss with the IPN listener & response system (and always has been) – and I requested an option to disable IPN error logging for that reason about 18 months ago. (See https://wordpress.org/support/topic/feature-request-disable-ipn-logging/ )

    So obviously the problem with the confirmation email is tied in some way to the IPN response from PayPal.

    If you cannot resolve this easily, I would be just as happy if I could have an option to BCC the Autoresponse that goes to the customer to the site administrator — that would actually be better, because then I would see what the customer is actually receiving, and with a bcc option there would be no need to also have the Confirmation Message under “Send Options”

    Sorry for all the confusion, but there isn’t an easy way for me to test without actually running payments through PayPal.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Problem with Email Confirmation since Update’ is closed to new replies.