WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Problem with Checkboxes

[Resolved] Problem with Checkboxes

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Till Krüss
    Participant

    @tillkruess

    Could you post 1-2 screenshots?

    eldenroot
    Member

    @eldenroot

    Same problem – there are the screenshots. It works fine in Firefox, but in Chrome or Opera checkboxes are broken (it is since first version of MP6)

    Google chrome (checkboxes are broken):
    https://www.dropbox.com/s/xmk5tu1b68g6rlq/GoogleChrome.jpg

    Firefox (checkboxes are fine):
    https://www.dropbox.com/s/vhe6v9o5o7kdmii/Firefox.jpg

    Opera 15: (checkboxes are broken)
    https://www.dropbox.com/s/97p56ok57zbxlx9/Opera15.jpg

    So, every plugin is affected by this when you use Opera or Chrome – webkit based browsers…. without MP6 plugin there is no problem with checkboxes

    Vikestart
    Member

    @vikestart

    I’m having the same problem

    Plugin Author Till Krüss
    Participant

    @tillkruess

    Could you send me a list of plugins/themes that aren’t showing the checkboxes?

    cosmicfantasia
    Member

    @cosmicfantasia

    Am having same issue with ACF check boxes when MP6 is on

    amcnaughton
    Member

    @amcnaughton

    The same thing happens with radio buttons in Chrome. They render as thin vertical lines unless the button has the “selected” attribute. Everything is fine in Firefox.

    Here’s an example of the HTML:

    <input type=”radio” name=”quiz_type” class=”wpcw_quiz_type wpcw_quiz_type_hide_pass ” value=”survey” style=”width: auto;”>

    I think the width:auto might be causing the problem.

    Here some of the CSS:

    media=”all”
    .form-table input.tog, .form-table input[type=radio] {
    margin-top: -4px;
    margin-right: 4px;
    float: none;
    }

    media=”all”
    input[type=checkbox], input[type=radio] {
    background: #fff;
    border-color: #bbb !important;
    color: #555;
    -webkit-box-shadow: inset 0px 1px 2px rgba(0,0,0,0.1);
    box-shadow: inset 0px 1px 2px rgba(0,0,0,0.1);
    }

    media=”all”
    .form-field input, .form-field textarea {
    border-style: solid;
    border-width: 1px;
    width: 95%;
    }

    media=”all”
    input[type=radio] {
    border-radius: 50%;
    margin-right: 4px;
    line-height: 10px;
    }

    Plugin Author Till Krüss
    Participant

    @tillkruess

    This should have been fixed in 768833. You can test it now by un-installing and re-installing MP6 (that’s going to install MP6 trunk).

    eldenroot
    Member

    @eldenroot

    Confirmed… it is fixed! Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Problem with Checkboxes’ is closed to new replies.