Support » Plugin: WP w3all phpBB » Problem using iframe feature with https

  • Resolved tlagren

    (@tlagren)


    Hi, I have been using the iframe feature which has been working great, but now when I have enabled SSL on my website I cannot load the forum in the iframe anymore. Everything worked well with plain http.

    This is what I did:
    – Enable Let’s Encrypt SSL feature frommy web hosting company
    – Changed the WP Setting about URL to the new https url
    – Changed the url to https in the w3all settings in WP
    – Changed from http:// to https:// in phpBB Admin Server settings
    – Updated the links in overall_footer.html so they use https instead of http
    – Enabled recompile in phpBB and loaded the forum from the direct link

    The forum is working without the iframe at https://wp2.transamclub.se/phpBB3

    Have I missed something?

    Update: I’m using the latest version of your plugin.

    /Tomas

    • This topic was modified 2 years, 11 months ago by tlagren.
    • This topic was modified 2 years, 11 months ago by tlagren.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author axew3

    (@axewww)

    did you switched to v3 code, then you updated/rebuilt also page-forum.php in accord?
    because it has been changed to work with v3 iframe code.
    On ACP
    Cookie settings -> cookie secure set to yes.
    Clean cookies?

    Thread Starter tlagren

    (@tlagren)

    Thanks for a very quick response. Yes, I copied iframeResizer.contentWindow.min.js from the plugin addon directory to the phpBB3 root folder. The version of the resizer is v3.6.2 – 2018-09-16 (first line in the js-file).

    I have rebuilt page-forum.php by clicking the “Create/Rebuild phpBB Page Template” button in WP Settings.

    I had forgot to change the cookie setting to secure, but it didn’t help after changing that. I have cleared all cookies, and also tried from other devices.

    When I visit the /forum url the Javascript executes and it tries to load the page, but the result is empty. I did also try to back to plain http again and then the forum is working again. So my problem is related to https.

    While comparing files I noticed that the page-forum.php is slightly different from the version in your TRUNK, but I guess you’re already on next version in TRUNK.

    $ diff page-forum.php page-forum.php_fromtrunk 
    275c275,276
    < if(/[^-0-9A-Za-z\._#\:\?\/=&%]/ig.exec(w3all_passed_url) !== null){
    ---
    > // security: do not pass to be encoded an url with sid or if point to phpBB admin ACP via iframe
    > if( /[^-0-9A-Za-z\._#\:\?\/=&%]/ig.exec(w3all_passed_url) !== null || /adm\//ig.exec(w3all_passed_url) !== null || /sid=/ig.exec(w3all_passed_url) !== null ){

    /Tomas

    • This reply was modified 2 years, 11 months ago by tlagren.
    Thread Starter tlagren

    (@tlagren)

    I just tried from an old Win7 computer with Internet Explorer and it’s showing the header of my phpBB forum. It looks like tha height of the ifrane is to small, but with Google chrome from the same Win computer it’s empty.

    So perhaps the forum is loaded, but just not visible if there are problem with the height of the iframe when using ssl?

    /Tomas

    Plugin Author axew3

    (@axewww)

    locked loading mixed active content “http://wp2.transamclub.se/phpBB3/”
    but as i see you’ve setup correctly all as need to be … what stupid situation … let me think on it a while more … bump …

    Plugin Author axew3

    (@axewww)

    p.s the above i see on console, it a js error that lead to this, did you cleaned phpBB cache? nor i imagine how could interfere but just in case …
    and eventually wp cache if there is some wp cache plugin.
    The url that point to load the phpBB into iframe is https, but the console return the above, so refuse to load and this the result. Why i have still not understand

    • This reply was modified 2 years, 11 months ago by axew3.
    Plugin Author axew3

    (@axewww)

    look that some image on phpbb are loaded as http, may this lead to the problem.
    How it is setup the url of phpBB?
    https or http? may this is the problem. Check general settings on acp

    • This reply was modified 2 years, 11 months ago by axew3.
    Thread Starter tlagren

    (@tlagren)

    Aah, I missed the warning in Chrome about it had blocked unsafe scripts. If I click on allow, then the forum loads nice. So then it’s back to the problem why this is happening. If I browse directly to the forum there are no warnings about mixed content.

    I did also check both the /phpBB3/ and /forum/ url with http://www.whynopadlock.com and that tool didn’t find any mixed content, but it was probably not able to load the javascript..

    I have no cache plugins installed in WP, I have deleted all files in the cache folder for phpBB3.

    Perhaps my hosting provider do have some caching because I don’t find any file or config where it points to http://wp2&#8230; as Chrome reports.

    I have to continue searching for this, thanks for your help so far.

    /Tomas

    Plugin Author axew3

    (@axewww)

    just in place finally after a long walk under 0 degree! that’s maybe more normal for you!

    Ok, look that there is no apparent reason for this but i can follow that now i’ve check more and:
    this the request:

    Host: wp2.transamclub.se
    User-Agent: Mozilla/5.0 
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-US,en;q=0.5
    Accept-Encoding: gzip, deflate, br
    Referer: https://wp2.transamclub.se/forum/
    DNT: 1
    Connection: keep-alive
    Cookie: phpbb3_jgdwe_u=1; phpbb3_jgdwe_k=; phpbb3_jgdwe_sid=92be3c746cedb2aa8d253539b102240c; cookie_notice_accepted=true
    Upgrade-Insecure-Requests: 1>

    and this the response:

    HTTP/1.1 301 Moved Permanently
    Date: Fri, 04 Jan 2019 18:38:10 GMT
    Server: Apache
    Location: http://wp2.transamclub.se/phpBB3/
    Content-Length: 241
    Keep-Alive: timeout=5, max=191
    Connection: Keep-Alive
    Content-Type: text/html; charset=iso-8859-1

    for some reason phpBB response is http 301, the reason is obscure to me at moment, may you can understand well having all under hand to test.

    Thread Starter tlagren

    (@tlagren)

    This time of the year we normally have a temperature below 0. Last year which was crazy with snow we had almost 1 meter and about -10 degrees but today there was 3-5 degrees plus and the little snow we have is melting. Hopefully it changes so we can have a real winter here in the north of Sweden.

    I have created a support ticket to my web hosting company and asked if there is any caching mechanism in place, still waiting for an answer.

    Regarding the HTTP 301 I did also notice that but it just when you don’t add the / (slash) in the end of the url. It’s them same with all WP urls, for example https://wp2.transamclub.se/kontakt so I guess it’s a WP feature.

    /Tomas

    Thread Starter tlagren

    (@tlagren)

    I did notice one other thing. When I click “Create/Rebuild page Template” in w3all settings I god the php error below.
    Notice: Undefined variable: w3all_pages in /wp2.transamclub.se/public_html/wp-content/plugins/wp-w3all-phpbb-integration/views/config.php on line 95 Warning: Invalid argument supplied for foreach() in /wp2.transamclub.se/public_html/wp-content/plugins/wp-w3all-phpbb-integration/views/config.php on line 95

    /Tomas

    Plugin Author axew3

    (@axewww)

    Regarding the HTTP 301 I did also notice that but it just when you don’t add the / (slash) in the end of the url. It’s them same with all WP urls, for example https://wp2.transamclub.se/kontakt so I guess it’s a WP feature.

    No Thomas i think it’s related to something else, but maybe i’m wrong.
    The link above not return the same, i may have explain in bad words what happen.
    What’s the content of your htaccess in phpBB?

    • This reply was modified 2 years, 11 months ago by axew3.
    Thread Starter tlagren

    (@tlagren)

    The phpBB .htaccess is default I think.

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ app.php [QSA,L]
    Options +FollowSymLinks
    </IfModule>
    <IfModule mod_version.c>
    	<IfVersion < 2.4>
    		<Files "config.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    		<Files "common.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    	</IfVersion>
    	<IfVersion >= 2.4>
    		<Files "config.php">
    			Require all denied
    		</Files>
    		<Files "common.php">
    			Require all denied
    		</Files>
    	</IfVersion>
    </IfModule>
    <IfModule !mod_version.c>
    	<IfModule !mod_authz_core.c>
    		<Files "config.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    		<Files "common.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    	</IfModule>
    	<IfModule mod_authz_core.c>
    		<Files "config.php">
    			Require all denied
    		</Files>
    		<Files "common.php">
    			Require all denied
    		</Files>
    	</IfModule>
    </IfModule>

    /Tomas

    Plugin Author axew3

    (@axewww)

    OK thank for report, i’ve see the error but it lead to nothing of problematic, i will fix but it not cause nothing of wrong, the page is correctly rebuilt, what happen is just that the old one isn’t replaced if you name a new page to build.
    I will go to patch this as soon.

    ABout the problem on iframe, and the wp htaccess?

    Thread Starter tlagren

    (@tlagren)

    Here is .htaccess for WP.

    <FilesMatch "^.*(error_log|wp-config\.php|php.ini|\.[hH][tT][aApP].*)$">
    Order deny,allow
    Deny from all
    </FilesMatch>
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    /Tomas

    Plugin Author axew3

    (@axewww)

    the reported bug about notice error when page-forum built has been fixed on repository, by the way as said it was leading to no problems.

    while also your wp htaccess say me nothing … wow …

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘Problem using iframe feature with https’ is closed to new replies.