Support » Plugin: Clef Two-Factor Authentication » Problem clef-require.php

  • Resolved Miguelonx

    (@miguelonx)


    Hi,
    I tried to access the administrative panel and could not enter because I was having trouble with clef.
    I decided to enter the ftp and disable clef renaming the file to let me go.
    In the end I entered and update de clef to the last version.
    when I tried to enter category of my Web, I showed me the following error:

    Warning: require_once(clef-require.php): failed to open stream: No such file or directory in /home/webs/public_html/web2.com/wp-content/plugins/wpclef/wpclef.php on line 32

    Fatal error: require_once(): Failed opening required ‘clef-require.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/web/public_html/web2.com/wp-content/plugins/wpclef/wpclef.php on line 32

    ¿can anybody help me?

    Thanks,

    https://wordpress.org/plugins/wpclef/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor inthylight

    (@inthylight)

    Greetings Miguelonx,

    I think the quickest way to fix things from this point would be to delete the re-named Clef plugin folder entirely, and then use the WP Dashboard to re-install the plugin.

    Can you give that a try and let me know whether that solves the issue for you?

    ¡Hi Laurence!

    Thank you for your help.
    I followed your advice but not be solved 🙁

    ¿Any alternative to fix this problem?

    Thanks!!

    Plugin Contributor inthylight

    (@inthylight)

    Good morning Miguelonx,

    I’ll need to gather some info about your site and your server setup. Can you send me an email (support@getclef.com), include your site’s URL, and I’ll follow up via email.

    Hi Laurence,
    I just sent an email

    Thanks for you help.

    Plugin Author Jesse Pollak

    (@jessepollak)

    Hi!

    We’ve identified the issue here — it was caused by a change in interface on a dependency that could be shared with other plugins and affects users that have certain combinations of plugins installed.

    We’ve pulled the 2.5.0 update from WordPress.org and are working on a fix, shipping Monday as v2.5.1. In the meantime, if you are affected, you should delete v2.5.0 of the plugin manually and install v2.4.1 from the plugin repository. If you have any issues, please email support@getclef.com and we will help you resolve them.

    You can follow our progress on this issue at status.getclef.com, thank you for your patience and sorry for the issues.

    Hi Jesse,
    That was the solution to my problem.
    Thanks for answer.

    Hi Laurence,
    Thanks very much for your support.
    You have been helpful for me.

    Plugin Author Jesse Pollak

    (@jessepollak)

    Hi! We have a beta release of v2.5.1 that we’d appreciate you testing. If you have a moment, would you go here and download the wpclef.zip plugin, install it, and let us know if there are any issues?

    Thank you for your help!

    Cheers,
    Jesse

    hello sir,
    I try to update clef and I got the same problem.

    Warning: require_once(clef-require.php): failed to open stream: No such file or directory in /home/u535378453/public_html/wp-content/plugins/wpclef/wpclef.php on line 32

    Fatal error: require_once(): Failed opening required ‘clef-require.php’ (include_path=’.:/opt/php-5.5/pear’) in /home/u535378453/public_html/wp-content/plugins/wpclef/wpclef.php on line 32

    Now, I could log in to my Dashboard or ftp my file. Please help me….
    TyDo

    14 Sep 16

    I have spent two or three days with this bug. Godaddy tech support advised me to disable clef until the problem is fixed.

    I tried four ways to set my password:
    1) through Godaddy’s cPanel (hosting –> applications –> myapplications –>edit
    2) through WordPress’s dashboard –> profile
    3) through the “lost password” (never received and email
    4) having Godaddy change the password.
    None were successful.

    The workaround was to disable clef.

    Let me know when it is fixed.

    Plugin Contributor inthylight

    (@inthylight)

    @gferry

    This issue was fixed a while back. Can you try the following:
    – double-check that your WP core is up to date
    – then perform a fresh install of the Clef 2FA plugin (i.e., delete any pre-existing versions)

    @laurence

    Is “a while back” further back than 26 August, because that is when I installed WordPress (4.6.1) and CLEF (I don’t know what version I had)?

    If it is, then the bug is that an installation through Godaddy is not loading the correct versions.

    Thanks for the advice, Laurance! Unfortunately my current situation makes it imprudent to make changes to a functioning system.

    Gregg

    Plugin Contributor inthylight

    (@inthylight)

    @gferry

    Yes, a while back as in version 2.5.1 in May 2016…but it sounds like outdated versions of core or the plugin is not the issue.

    If you’re still seeing this error, and if a fresh re-install (from the WP.com repository via your WP Dashboard -> Plugins menu, not from your GoDaddy control Panel) doesn’t resolve it, then there’s one more thing to check: test whether you are facing a theme/plugin compatibility issue.

    If you’re able to rule out a compatibility issue, then likely the best path for a resolution is to follow up with GoDaddy’s support.

    I have a similar problem now for a few days and no one at CLEF is responding. Meanwhile I am unable to login or administer my site. I have deleted the plugin folder but still can’t login. Maybe someone will give me an idea please. I have emails composed and need to send them out from the site and can’t get in.

    Jack,

    I totally gave up on Clef. A very cool concept but, without support, it is worse than useless. Particularly when both support entities point the finger at the other.

    rant begin

    In addition, from my perspective, WordPress lacks the necessary mechanisms to ensure that all of its plugins work. Yes, it is the plugin author’s responsibility to support the plugin, but it is ultimately WordPress’s issue.

    Likewise, when Godday put WordPress on its site, it is ultimately Godaddy’s responsibility.

    This is today’s sad state of affairs in that app authors/designers are just too cool to bother with some lowly task as support and blame the end user for their ignorance because, to the author, it is intuitively obvious and their code is perfect. Another lowly task that is totally ignored for the same reason is documentation.

    Godaddy and WordPress should improve their standards for allowing third party applications.

    rant end

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Problem clef-require.php’ is closed to new replies.