• Resolved Michal Janata

    (@kalich5)


    The plugin generated 1683 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; PageBuilder has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_pagebuilder.inc.php on line 25

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; FormBuilder has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_formbuilder.inc.php on line 74

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; FormElement has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_formbuilder.inc.php on line 743

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; TableBuilder has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_tablebuilder.inc.php on line 26

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; RowData has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_tablebuilder.inc.php on line 144

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; TableColumn has a deprecated constructor in /home/vu008154/www/wp-content/plugins/wp-portfolio/wplib/utils_tablebuilder.inc.php on line 280

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author puravida1976

    (@puravida1976)

    Hello,

    I suspect these errors are from an unsupported version of PHP. Could you please let me know the versions of WordPress, WP-Portfolio, PHP, and OS you are using?

    Thanks,

    Brandon

    PHP 7.1.6

    Plugin Author puravida1976

    (@puravida1976)

    Hi Michal,

    Thanks for your quick response. We do not yet support PHP7, due to lack of support by required libraries. Apologies. We will update when it is feasible to do so.

    Sincerely,

    Brandon

    Thank you for the info. But even so, it’s weird, the problem started yesterday. The web runs on PHP 7.x.x for more than half a year.

    Plugin Author puravida1976

    (@puravida1976)

    >> it’s weird, the problem started yesterday. The web runs on PHP 7.x.x for more than half a year.

    Hmm… Yes, that is weird then. While PHP7 is not supported, it “should” work. I just don’t test it, although it worked for me last year when I did test it.

    I am dealing with an issue caused by an accidental deployment of an unintended code change which has really wreaked some havoc. It may or may not have some bearing on your issue, but I cannot say until I deploy a workaround to fix the unintended code change.

    That said, the “deprecated” notices seem like an update was made that no longer accepts those functions OR perhaps a stricter validation was enforced (like the PHP deprecated error logging flag was enabled). Could that be the case?

    Cheers,

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    Hi Michal,

    Thank you for narrowing that down! We are so backlogged with urgent work and a new venture, so I cannot promise when we will be able to investigate further. However, your testing shows that they must have deprecated some functions between those versions. We will need to check with the WordPress library developers we rely on, to see if they have support for higher PHP versions (not using those deprecated functions).

    I will leave this as “Resolved”, since we do not -technically- support PHP7, and since we will eventually update the libraries, when possible.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.