Support » Plugin: Paid Memberships Pro » [pmpro_levels] not working

  • I have 3 membership levels, and my levels page only show 2. Site was working OK before updating PMPro 1.8.11.2.

    Currently site is running on WP 4.6.1, PMPro 1.8.11.2 as stated before. I did have a custom levels array function, but when I remove it levels page shows none of the levels. With the function it shows two.

    Any ideas?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Similar issue – Only had one membership level – now after updates registering user not prompted for level nor payment for the selected level

    Plugin Author Andrew Lima

    (@andrewza)

    Hey there,

    – What themes are you currently using?
    – Did your theme come bundled with PMPro?
    – Does your theme use a custom page template for the membership levels page?

    My theme, Kleo, won’t show any levels.

    Thanks for your response Andrew –
    – What themes are you currently using? Kleo (ChildVersion) By SeventhQueen
    – Did your theme come bundled with PMPro? No – Was already running on another theme – without issue
    – Does your theme use a custom page template for the membership levels page? No I dont believe so, Have tried both the Default template and full width template

    Plugin Author Andrew Lima

    (@andrewza)

    Could you please test this for me.

    1. Login to your site via FTP
    2. Navigate to ‘wp-content’ > ‘themes’ > ‘kleo’ (Please go into your parent theme)
    3. Navigate inside your parent theme, to: ‘paid-memberships-pro’ > ‘pages’ > ‘levels.php’
    4. Rename your ‘levels.php’ to ‘levels-old.php’
    5. Revisit your [pmpro_levels] page and see if it’s displaying correctly?

    Please keep me posted.

    Plugin Author Andrew Lima

    (@andrewza)

    The above will temporarily disable the custom levels template that the theme is using, and revert back to PMPro’s original levels template.

    This will help pinpoint the issue 🙂

    Hi Andrew,

    Thank you for the through steps – I have followed them to the T (and cleared all caches) – unfortunatly the issue persists – I will rollback the changes now

    Hey Andrew – Anything else you can think of please?

    Plugin Author Andrew Lima

    (@andrewza)

    I do believe that Kleo has released an update to address this issue. Can you please ensure you are running the latest version of Kleo?

    If you still don’t come right, I would suggest contacting Kleo support as the issue is coming from their side (from what I understand).

    Alternatively, you can sign up for premium support from Paid Memberships Pro and get troubleshooting assistance from their team 🙂

    *PS – my apologies for the delayed response.

    Thanks Andrew – I can confirm i see in the changelog for Version 4.1.6 – 21.10.2016
    – Paid Memberships Pro Levels page template fix to work with the latest update

    I’ll get this updated later today and hope we are all good 🙂

    Thanks for your help!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[pmpro_levels] not working’ is closed to new replies.