Support » Plugin: Hustle - Pop-Ups, Slide-ins and Email Opt-ins » [Plugin: WordPress PopUp] Annoying message on top…

Viewing 1 replies (of 1 total)
  • I just updated WordPress PopUp, and am now also getting this red notification to install another plugin.

    What’s worse is that I would be forced to sign up and join WPMU before I can get said plugin that doesn’t add any functionality or benefit to me… the only WPMU plugin I’m using is PopUp, and if I’m being forced to join yet another freaking WP club in order to keep my websites up to date, then I’m looking for a new PopUp plugin.

    It’s a free plugin… I should NOT have to sign up for something I don’t need in order to keep using it, or to make you to feel special by keeping track of where your plugin’s being used.

    Seriously, some of this “join my WordPress island or you can’t play with my toys” crap is going too far.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WordPress PopUp] Annoying message on top…’ is closed to new replies.