Support » Plugins and Hacks » [Plugin: Sendit] Widget doesnt work

[Plugin: Sendit] Widget doesnt work

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi i just try in a lot of websites and everything looks ok? can you send me the url?


    Here you have it: http://securix.security-portal.cz/

    I hope that settings from previous version cant affect this, but I just tune CSS settings.

    Thank you

    Hi! I update the plugin to fix an issue that was unable to create the field to email table so upgrade to 2.0.4!

    Oh great response!

    But still no luck… I’m unable to see button or text field for mail address. Subscribers as well.

    Isn’t there something else? Should I test something on my side?

    Thank you

    Any update?

    Thank you

    Hi bro!

    I’m working like a crazy man these days to fix everything on the plugin.
    Probably something wrong happens with the html and css of widget, another customer report to me the same problem.
    Try to see from the menu in the wp-admin left bar Widget settings and if you see empty the first 2 textareas is missed evrything im upgrading the plugin to fix this but if you find the field empty just put this:
    in html code (the first textarea whiteone)
    <!– Start Sendit Subscription form –>
    <div class=”sendit”>
    <h4>Subscribe to our newsletter</h4>
    <form name=”theform” id=”senditform”>
    <!– the shortcode to generate subscription fields –>
    <p><label for=”email_add”>Your email</label>
    <input id=”email_add” type=”text” placeholder=”email here” name=”email_add”/>
    <input type=”hidden” name=”lista” id=”lista” value=”{list_id}”><div id=”sendit_wait” style=”display:none;”></div>
    <input class=”button” type=”button” id=”sendit_subscribe_button” name=”agg_email” value=”{subscribe_text}”/>
    <div id=”dati”></div>
    <small><i>You will receive an email with the confirmation link (check your spam folder if NOT)</i></small>

    <small>Sendit WordPress newsletter</small>

    and in the CSS field (the black one) this code: you can change both to customize the appearance

    border-radius: 10px;
    padding:10px 5px 10px 5px;
    border:10px solid #efefef;
    .sendit h3, .sendit h4{
    .sendit label{
    font-weight: bold;
    #sendit_subscribe_button{margin:5px 0;background:#ff9900;color:#fff;}

    .sendit input, .sendit textarea, .sendit select{
    /*width: 180px;*/
    border: 1px solid #BBBBBB;
    border-radius: 2px 2px 2px 2px;
    margin: 0 5px 0 0;
    padding: 4px;

    width: 100px;
    margin-bottom: 5px;

    .sendit textarea{
    width: 250px;
    height: 150px;

    width: 1em;


    margin-top: 5px;
    width: 180px;

    .sendit br{
    clear: left;

    .info, .success, .warning, .sendit_error, .validation {
    border: 1px solid;
    margin: 5px 0px;

    .info, .notice{
    color: #FFD324;
    background-color: #FFF6BF;
    .success {
    color: #4F8A10;
    background-color: #DFF2BF;
    .warning {
    color: #9F6000;
    background-color: #FEEFB3;
    .sendit_error {
    color: #D8000C;
    background-color: #FFBABA;
    .sendit small{font-size:80%;}

    Hi man,

    it looks like move forward. I will test if registration, ect works and let you know.

    Thank you

    i’m still developing the 2.0.6 i wish to fix this on plugin activation
    Can you send me the url where Sendit run?

    Bro the 2.0.6 is out now!!

    try it and let me know

    Guys i discover this issue not by me but by the hooks so some stuffs doesn’t happen when upgrding all plugins via svn.
    I tryed in another new wordpress installation. Uploading 1.6.2 and then upgrade to last version. Actually when auto upgrade the register activation hook fault and this is a current wordpress issue:
    But if you deactivate and reactivate the plugin you will see all default value correctly so basic it doesn’t setup the default options (html to generate the widget and css). Just DEACTIVATE and RE ACTIVATE Sendit


    I have 2.0.6 version and already perform activate/deactive.

    Registration and confirming works. Also I see now list of users.

    Another bugs:
    – doesnt matter if I setup Ajax or Alert, but when I put new mail address (to widget) user dont receive any confirmation about registration. Yes mail is working, but to confirmation after click on “Subscribe”.

    Another feature: cant Sendit use WP better email?

    Thank you

    Hi martin.cmelik!

    Do you can solve the problem? I have the same..

    The widget shows the subscribe button, and when I click not show’s anything… I use the 2.0.9 version..

    I send the mails ok, but i can subscribe users…

    Thank’s! & Regards!

    Hi estteban,

    please try to completely uninstall plugin, and put it back. It helps in my case.

    Thank you

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Sendit] Widget doesnt work’ is closed to new replies.