WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Popular Widget] invalid HTML – p inside span

[Plugin: Popular Widget] invalid HTML – p inside span

  • When I use this plugin it causes a validation failure because it generates P tags inside SPAN tags. Please could you fix this when you next update. I have successfully fixed the problem by replacing the span tags with div tags as detailed below…

    On lines 114, 174, 237, 288
    replace: $output .= isset($image) ? $image.'<span class="pop-overlay">':'<span class="pop-text">';
    with: $output .= isset($image) ? $image.'<div class="pop-overlay">':'<span class="pop-text">';

    On lines 121, 182, 246, 295
    replace: $output .= '</span></a><div class="pop-cl"></div></li>'; $count++;
    with: $output .= '</div></a><div class="pop-cl"></div></li>'; $count++;

    This doesn’t seem to have had any negative side effects but I haven’t checked all configurations for any css errors

    http://wordpress.org/extend/plugins/popular-widget/

  • The topic ‘[Plugin: Popular Widget] invalid HTML – p inside span’ is closed to new replies.