WordPress.org

Support

Support » Plugins and Hacks » Google+ Crossposting » [Plugin: Google Crossposting] Invalid argument supplied for foreach

[Plugin: Google Crossposting] Invalid argument supplied for foreach

Viewing 5 replies - 1 through 5 (of 5 total)
  • Well … turns out you have to actually activate the G+ API in it’s interface, which i didn’t 🙂 anyways:

    foreach ((array) $activities->items as $activity)

    should prevent the error, although before traversing this object you should check if it has an ‘error’ item and instead display this.

    Plugin Author Sebastian

    @sebstein

    Good point, will check it.

    Plugin Author Sebastian

    @sebstein

    I just released version 1.0.1 of the plugin fixing the problem you reported above. The validation of the settings entered is now more careful. If the settings are wrong, the are reset to empty strings.

    At a later point, I will try to figure out how to do correct error reporting to the admin user. I was not able to find a good description how to keep error messages between page views. I would be happy for any pointers.

    Just write your own in “wp_options”?

    What you got here is not exactly an error, it’s a misconfiguration by us users, so in my mind you should write a decent doc and put it somewhere under the help panel on your plugins option page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Google Crossposting] Invalid argument supplied for foreach’ is closed to new replies.
Skip to toolbar