Support » Fixing WordPress » PHP & WordPress v5.1.1

  • Resolved raymondbolton

    (@raymondbolton)


    What is the most recent version of PHP that’s compatible with WordPress 5.1.1? Apparently, PHP 7.2 is incompatible.

    • This topic was modified 4 months, 4 weeks ago by  raymondbolton.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Apparently not, I’ve seen numerous WP websites working perfectly well with PHP 7.2. There’s also https://wordpress.org/about/requirements/.

    So what’s made you think it’s not compatible? Do you have some specific issue?

    PHP 7.2 is compatible with WP 5.1.1. All of my sites use 7.2. Actually PHP 7.3 is the recommended version. Please elaborate on your concerns.

    After my website crashed, I contacted iPage technical support (because I lack the necessary expertise‚Ķ my talents lie elsewhere). After several days of back-and-forth discussions as to where the problem might lie, they responded, “The script installed at http://www.raymondbolton.com looks to be incompatible with Php 7.2. I had to switch PHP version back to 5.6 and http://www.raymondbolton.com/ is loading fine now. Please try upgrading your WordPress to the latest release to use latest PHP.”

    I am currently running WordPress 5.1.1, so I naturally assumed there must be a compatibility problem.

    iPage just updated the PHP to v7.3 and now the site is loading just fine.Thanks @sinip and @bigmoxy!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.