Support » Plugin: tinyCoffee » “PHP warning” error

  • Resolved Jeremy Hammond

    (@jrh001)


    My error log is showing the following after installing and activating this plugin:

    PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, cannot access private method Tiny_Coffee::get_fontawesome_version() in [path ommitted]/wp-includes/class-wp-hook.php on line 298

    I’m happy to help troubleshoot to fix this problem. Please advise.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Arunas Liuiza

    (@ideag)

    Thank you for reporting this, Jeremy. I really appreciate it. I’ll look into it later today. Did this happen only on activation, or does it happen on every page load?

    I installed and activated it several weeks ago, sometime before March 14. I see three times this error triggered in my log, once each on March 21, 22, and 23. I do not have any guesses as to what might have occurred at those times to trigger it. I don’t recall doing any work on the site in recent days that might do so (e.g., deactivating and reactivating the plugin, etc.

    However, I did just deactivate and reactivate the plugin, and this did trigger the error.

    Plugin Author Arunas Liuiza

    (@ideag)

    Hi again. I’ve made a fix for this issue and pushed a new version (0.2.2) to WordPress.org. It should be available shortly.

    It wasn't anything serious, just a periodic call to check for new FontAwesome versions was not working properly. But I am still happy we caught it.

    Thanks again for reporting this and let me know if you have any more issues.

    Ar┼źnas

    Thanks for the update!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“PHP warning” error’ is closed to new replies.