Support » Plugin: Polylang » PHP Warning

  • Resolved Spiffy Plugins

    (@spiffyplugins)


    Thank you for this plugin. I am evaluating for potential use on a new website. I have found the following PHP error warning is generated:

    Declaration of PLL_Walker_List::walk($elements, $args = Array) should be compatible with Walker::walk($elements, $max_depth, …$args) wp-content/plugins/polylang/include/walker-list.php:65

    I am using version 2.6.6.

Viewing 15 replies - 1 through 15 (of 47 total)
  • Plugin Author Chouby

    (@chouby)

    Hello,

    I will stick this topic.

    This is a known issue since WP 5.3. With this new release, we had to choose between having this warning or stop supporting PHP < 5.6, even for older versions of WordPress as it’s currently not possible to support older versions of PHP for older version of WordPress without having this warning in WP 5.3.

    Considering that this warning has no impact on the way the plugin works (just set WP_DEBUG to false in production and that’s ok) and the fact that we don’t want to change the PHP min version in a minor release, the issue will stay as is in WP 5.3 + Polylang 2.6.x.

    The warning is already fixed in the development version of Polylang 2.7, for which we will require PHP 5.6 or older. See https://github.com/polylang/polylang/issues/414

    See also https://make.wordpress.org/core/2019/10/09/wp-5-3-introducing-the-spread-operator/ for the WordPress background.

    I had to add @ini_set( 'display_errors', 0 ); to get rid of the error message.

    Nikita_Sp

    (@nikitasp)

    @chouby hi!

    The thing is that

    just set WP_DEBUG to false in production and that’s ok)

    is NOT working.
    I’ve got the same issue and there is WP_DEBUG false in my wp-config.php.

    Thanks.

    setevoy

    (@setevoy)

    > just set WP_DEBUG to false in production and that’s ok)

    @chouby +1 – doesn’t work for me too (PHP 7.0.33-0+deb9u6)

    @mstuyts @ini_set( 'display_errors', 0 ); – where did you added this? Tried add to the wp-content/plugins/polylang/polylang.php – no result.

    mstuyts

    (@mstuyts)

    I added it to wp_config.php.

    katastrophenschutz

    (@katastrophenschutz)

    Same here.
    Using WP 5.3, PHP 7-72STABLE-STANDARD, Polylang 2.6.6

    WP_DEBUG is set to false, but error is still displayed.

    EDIT: Can I revert plugin to an older version and would that help?

    Plugin Author Chouby

    (@chouby)

    This is a warning. This message is for developers and must never be displayed on a production site. If the message is displayed while WP_DEBUG is set to false and you don’t know what to do, please contact the support of the host provider and ask how not to display warnings.

    studiomondiale

    (@studiomondiale)

    Same issue here and WP_DEBUG is already set to false.

    Found the solution:
    Add “php_flag display_errors off” (without “) to your .htaccess

    • This reply was modified 2 months ago by studiomondiale. Reason: solution
    • This reply was modified 2 months ago by studiomondiale. Reason: solution
    katastrophenschutz

    (@katastrophenschutz)

    Thanks, I contacted our provider’s support…

    setevoy

    (@setevoy)

    I had php_admin_value[display_errors] = 'stderr' im my /etc/php/7.0/fpm/pool.d/rtfm.co.ua.conf.
    Changed to the php_admin_value[display_errors] = off and all good now.
    I thought stderr means write to the php_admin_value[error_log] 😐
    Anyway – the warning gone now.

    mrtvy.kenny

    (@mrtvykenny)

    well this is very much unfortunate as i manage tens of websites and now i have to go thru all of them and change config…

    it was not possible to do some intelligent fallback? i mean you know what php version is running, if you want to keep support for older php, you could do just put switch in the code..

    now my day is going to be just about this problem, so thanks ;(

    Fee

    (@wdfee)

    @chouby I’m a developer and really don’t like this statement “just set WP_DEBUG to false in production and that’s ok” because that’s no clean way of coding.
    In my opinion it’s time skipping support for PHP < 5.6 as most providers already skipped that.
    Your milestone 2.7 is 100% complete – when will this version be released? What’s missing?

    katastrophenschutz

    (@katastrophenschutz)

    SOLVED here.

    My host provider allows to use a custom php.ini.

    Following the suggestion from @setevoy I set display_errors to Off and now we#re fine.

    Thanks…

    dashamiro

    (@dashamiro)

    I use the excellent plugin on several sites.
    Is it worth it to wait for a solution with support?
    (I really do not want to use crutches -> display_errors Off).

    Or is this your final decision – and everyone will still have to turn off PHP Warning?

    Nikita_Sp

    (@nikitasp)

    @wdfee I’m agree with you. Also could you just check what version of PHP is using and then use different methods depending on the version?

    Waiting for an update…

Viewing 15 replies - 1 through 15 (of 47 total)
  • You must be logged in to reply to this topic.