Support » Plugin: Infusionsoft Gravity Forms Add-on » PHP error with this plugin

  • I put this comment in a different post thread then realized I should start a new one, sorry for causing any confusion!

    I’m having a problem for which I could use some help, this plugin is now giving this error (although it doesn’t seem to be preventing GF form submission):

    Warning: count(): Parameter must be an array or an object that implements Countable in [mysite]/wp-content/plugins/infusionsoft/Infusionsoft/xmlrpc.inc on line 2623

    For anyone who doesn’t have the same version of this plugin that I do (version 1.5.12) here is lines 2622 and 2623, to help you find the same section that is causing this error:

    // first error check: xml not well formed
    if(!xml_parse($parser, $data, count($data)))

    My best guess is that it’s a PHP compatibility error, our site host forced us to update our PHP version to 7.3 and our WP to 5.3.2, so I’m guessing it’s that the plugin hasn’t been updated in so long it uses a much older version of PHP.

    Any suggestion at all as to how I can modify my file (referenced in the error message) to fix this would be MUCH appreciated, I’m not a coder but very capable of following instructions!

    @justinhandley I hope this isn’t inappropriate but I’m tagging you since you mentioned taking over this plugin. 🙂

    • This topic was modified 1 year, 3 months ago by TrishaM.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Hey There,

    So, two things..

    1. That error doesn’t (really) matter – it won’t break anything. You shouldn’t have debug mode on in production, and it is just a warning, not a failure, so if you are on a live site you shouldn’t see that show up at all.

    Having said that, it is deep in the core of a legacy Infusionsoft SDK, which we are trying to get rid of entirely, which is why it is taking so long. Even our updated version currently throws that error – until we can replace the whole Infusionsoft connection it will stay there, as it is in their old XMLRPC api code, notthe plugins code at all.

    Thread Starter TrishaM

    (@trisham)

    Hi @justinhandley – Thank so much for the quick reply, the explanation, and the reassurance!

    I actually have WP_DEBUG set to false in my wp-config file….and the debug mode checkbox is not checked in this plugin’s settings, nor is logging set in my GF settings.

    That error only shows very, very briefly (on the front end) when a form is submitted….just a flash really, then the form submits, so it’s doubtful that it would disturb site visitors. It does show up in the back-end on this plugin’s settings page, which is where I was able to copy & paste it from.

    But I’m glad to know I don’t need to worry about it, I’ll just wait for [your] new plugin. 🙂

    Hello.

    I am having this error as well, though it is visible to my website users. How do I get rid of it?

    Thread Starter TrishaM

    (@trisham)

    Hi @lahiggins – I have not found any way to get rid of the error message short of removing the plugin, even with debugging set to ‘off’ in both GravityForms and WP. I tried a couple of similar plugins but they did not perform as well as this one, and did not allow me to map to custom fields.

    My best suggestion (while waiting for an update to this one) is to redirect form submitters to a different page instead of just displaying a confirmation message…that way the error is brief and *if* they see it, it’s only until they get the next page. Once they get a confirmation page, letting them know that their form was successfully submitted, they won’t worry about an error message.

    • This reply was modified 1 year, 2 months ago by TrishaM.

    I’m getting the same here as well. And have WP_DEBUG set to false.

    So is the recommendation to just move away from this plugin at this point @justinhandley ?

    I appreciate your suggestion too @trisham but that still doesn’t really work.

    Hey Guys – sorry – just an update.

    We should be submitting the new version using Oauth and the current REST API to WordPress tomorrow or the next day. We have it all working, and the only issue right now is that data mapping is different, so when you upgrade your maps are all lost. We are working on resolving that, but a shiny new version should hopefully be out in a week or so.

    Sorry for the delay. We basically ended up having to rewrite the whole thing from scratch. On a positive note, our version does some cool things like.. let’s gravity form cookie just like Infusionsoft so affiliate tracking and web based automation work.

    Thread Starter TrishaM

    (@trisham)

    YAY! Awesome news, @justinhandley!

    Just a quick question – when you say the maps are all lost, we can still re-create them, correct?

    I’ve been testing two other similar plugins (both had the same PHP error) so I’ve learned that it doesn’t’ take me very long to recreate a feed and map our form fields to the custom fields setup in Infusionsoft….in fact I’m pretty quick at it now! So as long as that will still be possible then I am REALLY looking forward to your update!

    KUDOS AND HUGS! <3

    @justinhandley super glad to hear that.

    @trisham sounds like I’m on the same path you are.

    I did install Jeff Chimene’s plugin (https://wordpress.org/plugins/systasis-gf-infusionsoft-feed/) as it leverages Joey Novak’s Infusionsoft SDK plugin. In what I found, it was conveyed that should take care of the error. It’s an Infusionsoft XMLRPC issue.

    Digging into this plugin, I see that the Infusionsoft SDK is embedded in it.

    Wondering if either of the updates to Novak’s Infusionsoft PHP SDK can be used inside your plugin to make those errors go away until the launch of the new version?

    https://github.com/novaksolutions/infusionsoft-php-sdk
    https://github.com/novaksolutions/infusionsoft-sdk-for-wordpress

    @justinhandley do you know if that Infusionsoft folder inside your plugin has a heavily modified version of that? And wouldn’t work? I’m trying to replace that folder with the Novak version & see if I can get this version working.

    (Long time Infusionsoft Certified Consultant who knows these folks btw…)

    @trisham actually that worked!!

    I replaced the contents of the Infusionsoft folder in the plugin with the contents of the Infusionsoft folder I downloaded from https://github.com/novaksolutions/infusionsoft-php-sdk

    My submission came over into Infusionsoft and all of the automation happened.

    No “Countable” errors anymore.

    So I’m sorted until the new version of this plugin comes out.

    @justinhandley you might want to test yourself but if that gives you some relief, you’d have time to figure out the migration of the existing mappings.

    Cheers.

    Thread Starter TrishaM

    (@trisham)

    @chrislee @justinhandley thank you both so much for working on this!

    I discovered that if I add this to my wp-config.php then at least I can keep the error from showing visibly on the website, which buys some time:

    define(‘WP_DEBUG_DISPLAY’, false);

    (That is in addition to the normal WP_DEBUG being set to false)

    I did try the plugin you recommended (by Systasis) and it’s a good plugin, but it lacks the ability to add Tags to the data sent to Infusionsoft. The developer recommended using a Campaign to set the Tag, but for us that isn’t possible – the Campaign applied to the lead is determined by the Tag sent with the form submission…..he suggested using the Conditional API Goal to set the Campaign, but I’m having trouble figuring that part out, the docs on doing that are too brief for this blonde…..I need pictures LOL (kidding, but better instructions might help).

    SO I’m going to wait for Justin’s updated plugin, the old one at least still works and now I don’t have the error showing on the website, so I’m good for now.

    HUGS to both of you!

    @justinhandley brother, I need serious help. We’ve got tons of forms that’s like 2-3 weeks of worth for me if I don’t get this plugin to work.

    So, I suspect that this plugin is causing this error in our website. https://drive.google.com/file/d/19-d5MqM-H3frOSuZ3_2hNlIZI_fEjAiU/view?usp=drivesdk

    One of the example errors one of our guys found is this
    “Speaking of PHP errors, there are a TON of warnings that Gravity Forms can’t modify header information because the Infusionsoft plugin has already sent the headers to the client. No telling what problems this is causing, but this would likely be the Infusionsoft plugin violating WordPress best practices. Example:

    [14-May-2020 20:24:09 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/childc32/public_html/childcaresuccess.com/wp-content/plugins/infusionsoft/infusionsoft.php:1719) in /home/childc32/public_html/childcaresuccess.com/wp-content/plugins/gravityforms/form_display.php on line 215”

    Are you able to take on projects and be an angel to our company? If yes, can you please pick your preferred time and day here so we can discuss? https://www.scheduleyou.in/hgmR6Kqz

    @justinhandley do you have an ETA when WordPress will approve the new version?

    I don’t have a solid idea. We are still in communication trying to get the rewrite approval ready – that will hopefully happen this week – so maybe sometime next week if all goes well.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘PHP error with this plugin’ is closed to new replies.