Support » Plugin: Download Monitor » PHP 7 Compatibility? Breaking.

  • Resolved ciordia9

    (@ciordia9)



    PHP Fatal error: Uncaught Error: Call to undefined function mysql_real_escape_string() in /srv/www/tld.com/public_html/wp-content/plugins/download-monitor/admin/add_new.php:164\nStack trace:\n#0 /srv/www/tld.com/public_html/wp-includes/plugin.php(524): dlm_addnew('')\n#1 /srv/www/tld.com/public_html/wp-admin/admin.php(222): do_action('downloads_page_...')\n#2 {main}\n thrown in /srv/www/tld.com/public_html/wp-content/plugins/download-monitor/admin/add_new.php on line 164, referer: http://tld.com/wp-admin/admin.php?page=dlm_ad

    Upgraded to Ubuntu 16.04.1 LTS which switched me from PHP 5 to 7. Your plugin seems to still work on most functions, but I cannot add anything new.

    https://wordpress.org/plugins/download-monitor/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hello @ciordia9,

    Can you please confirm if you are using the latest version of our plugin “1.9.5”?

    ciordia9

    (@ciordia9)

    This has made me realize I’m running the legacy code from the prior iteration 3.3.6.1 — you know things run great until they don’t, then you figure out where you are.

    Do you think I can run the Legacy Converter, delete the old DM, and install the new one, and be good-to-go? Based on iconography between the github transition it matches.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7 Compatibility? Breaking.’ is closed to new replies.