Support » Plugin: BuddyPress Links » PHP 7 compatibility?

  • WP Engine PHP Compatibility Checker plugin reports:

    ILE: /nas/content/live/dereg/wp-content/plugins/buddypress-links/bp-links-templatetags.php
    ———————————————————————————————–
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ———————————————————————————————–
    25 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1177 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————–

    FILE: /nas/content/live/dereg/wp-content/plugins/buddypress-links/bp-links-widgets.php
    ———————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————
    12 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————

    FILE: /nas/content/live/dereg/wp-content/plugins/buddypress-links/bp-links-core.php
    ————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————–
    349 | ERROR | Function split() is deprecated since PHP 5.3 and removed since PHP 7.0; use preg_split instead
    ————————————————————————————————————–

    FILE: /nas/content/live/dereg/wp-content/plugins/buddypress-links/bp-links-classes.php
    ———————————————————————————————–
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ———————————————————————————————–
    236 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1046 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1263 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————–

    Any plans to deal with these issues?

  • The topic ‘PHP 7 compatibility?’ is closed to new replies.