Support » Plugin: Yoast SEO » Permalink Issue

  • Resolved Noor Alam

    (@naa986)


    When I create a new post titled “How to Do Something” this is how the permalink is shown in the edit screen:

    Permalink: https://example.com/do-something/

    But when I save it as draft or publish, it becomes:

    Permalink: https://example.com/how-to-do-something/

    I understand that Yoast SEO automatically removes stop words from the URL (and I like that too). But why is it saving https://example.com/how-to-do-something/ when it’s showing https://example.com/do-something/ in edit mode?

    I’m having to manually edit the permalink after saving/publishing a post.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Rumejan Barbarona

    (@onlyincebu)

    If Yoast SEO is changing your slug for you, and you don’t want it, you can disable that functionality under SEO → Advanced→ Permalinks menu. Please refer to this kb article: https://kb.yoast.com/kb/wordpress-seo-is-changing-my-slug/.

    @onlyincebu, Did I say that I don’t like that feature? I’m trying to report a potential bug in the post edit screen when this feature is enabled.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for bringing this to our attention @naa986. While Yoast SEO doesn’t remove the stop words from slug when saving a post or page as the draft, we can confirm that when you publish it, the stop words will be removed from the slug by Yoast SEO.

    That said the Yoast SEO should still remove the stop words from the slug when saving the page or post as a draft. So, we are expecting this to be a bug. We’re actively using the bug tracking on our GitHub repository so your best next step would be to create a new issue for our developers at https://github.com/Yoast/wordpress-seo/issues/new. You will need an account to create a new issue. If this is your first bug report, please check out: https://kb.yoast.com/kb/how-to-write-a-good-bug-report/.

    Don’t forget to include the URL to this conversation in your bug report.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to open a new topic. Please read this post before open a new request.

    Thanks for understanding!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Permalink Issue’ is closed to new replies.