Support » Plugin: Ocean Extra » oceanWP extra – Notice: Undefined index:

  • pineview

    (@pineview)


    My theme is oceanWP and recently I got the oceanWP extra plugin and now I have this “undefined index” notice that comes up at the top of every page. I do not have a custom menu widget or any widgets for that matter. could someone please help

    Notice: Undefined index: dropdown in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 234 Notice: Undefined index: target in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 235 Notice: Undefined index: dropdown in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 234 Notice: Undefined index: target in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 235

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 33 total)
  • Amit Singh

    (@apprimit)

    Hello,

    Try to follow the below steps and see it fixes the issue or not.
    1. Update PHP version if it is not PHP7
    2. Disable all plugins except Ocean Extra and check it works or not
    3. Update all the plugins and theme to the latest version
    4. Go to Theme Panel > Scripts & Style, disable all – save settings, then enable it again. Clear cache and check it works or not.

    • This reply was modified 4 months ago by  Amit Singh.
    pineview

    (@pineview)

    Thank you Amit! I’ve tried your suggestions and I still have the same issue! I believe that OceanWP extra and Elementor are having communication problems.

    Amit Singh

    (@apprimit)

    Can you please tell me the steps to replicate the issue so that I can check it on my end?

    pineview

    (@pineview)

    just go to the website and you will see the Notice code come up
    http://www.pineviewbaptistchurch.net

    Amit Singh

    (@apprimit)

    Go to Customize > Header > Menu and unselect menu if you have any. I saw the error on your site but I’m asking to replicate the issue so that I can check it on my end.

    pineview

    (@pineview)

    Hey Amit. I went to Menu and there wasn’t a place to unselect menu… Is there any other information that I can give you.

    Mitch

    Amit Singh

    (@apprimit)

    It is difficult to give the correct solution without seeing the site settings since our support is limited here. Hope you understand it.

    Can you share the screenshots of the Customize > Header > menu section?

    pineview

    (@pineview)

    I am super thankful for all your help!! I would give you my username and password if that would help!! I am a desperate man….

    … I tried to put in the picture but this text box will not allow it

    Amit Singh

    (@apprimit)

    No, it is not allowed to share the login details or asking for it. It is against the forum guidelines. To share the image of the menu section, you can use tools like Imgur and Lightshot.

    pineview

    (@pineview)

    Amit Singh

    (@apprimit)

    That’s odd. Edit the footer and remove the custom menu widget. Check it fixes the issue or not.

    pineview

    (@pineview)

    http://prntscr.com/ng931n

    I don’t have a custom menu widget

    Amit Singh

    (@apprimit)

    See the screenshot – http://prntscr.com/ngb4hx
    You have a custom menu widget in the footer. Go to Dashboard > Theme Panel > My Library and edit the footer template. Now remove the custom menu widget.

    pineview

    (@pineview)

    I deleted the footer template. Didn’t fix! I am so sorry for this never ending issue!!
    http://prntscr.com/ngga4g

    pineview

    (@pineview)

    I don’t know if it’s related but I am getting a lot of spam emails from the “contact” section of our website. They all come through WordPress and hit my personal inbox. This just started happening about a month ago or so.

    Mitch

Viewing 15 replies - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.