Support » Plugin: Ocean Extra » oceanWP extra – Notice: Undefined index:

  • pineview

    (@pineview)


    My theme is oceanWP and recently I got the oceanWP extra plugin and now I have this “undefined index” notice that comes up at the top of every page. I do not have a custom menu widget or any widgets for that matter. could someone please help

    Notice: Undefined index: dropdown in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 234 Notice: Undefined index: target in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 235 Notice: Undefined index: dropdown in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 234 Notice: Undefined index: target in /hermes/bosnaweb23a/b2479/ipg.pineview/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php on line 235

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 33 total)
  • Do one more thing, delete you footer and recreate it. I hope it should fix this strange issue. For the spam, you can use a plugin like Akismet to prevent it.

    Hey Amit. I hope your having a great week!

    I did what you asked and I still have the issue…

    I might have to change my theme – which I really don’t want to do!!

    I checked your site again and the footer is still there with the custom menu widget. You need to check your footer settings and design again.

    Do you see anything here?
    http://prntscr.com/ngu54i

    Hello,

    I don’t know how you have designed your footer but this issue is coming from your footer section.
    You have called elementor template in your footer, right? Try to remove that Elementor template and check it fixes it or not.

    When I deactivate OceanWP Extra plugin the notice goes away. It creates other issues but I might be able to fix those…
    http://prntscr.com/nh6yas

    Yes, because of the OceanWP custom Menu is the part of the Ocean Extra plugin. Why you are not trying to remove/re-add the menu in the footer section?

    how exactly can I do that?

    Open your site (frontend) and hover over the Edit with Elementor on the wordpress toolbar. You will see a dropdown. Just click on the footer template to edit it.

    Hey Amit, you’ve been a great help! Thank you for all the time..

    So, when I hover over the “Edit with Elementor” at the top of my site it has no dropdown. I can only click the “Edit with Elementor” then it opens to the Elementor and the footer isn’t available to to change in Elementor.

    Back to you!!

    Mitch

    You haven’t given up on me have you?

    Mitch

    Our support is limited here and we can’t ask additional details. I don’t know how you build your footer but seeing the source code, it seems it is coming from the Theme Pane > My Library – custom footer template. And the error is appearing due to the footer.

    This is my Library – http://prntscr.com/nj2tau

    This is the “footer” I put in the trash – http://prntscr.com/nj2umx

    Should I restore it?

    Try to delete it and check it works or not. Are you using Elementor Pro or any other Header and Footer plugin?

    We can’t provide more support here because it requires extra information that we can’t ask. Our support is limited here. Hope you understand it.

    THAT DID IT!! I deleted it from trash and now no code at top of page. So, now what do i do to get my footer back?

    Amit you’ve been super helpful and very patient – thank you!!

    Mitch

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘oceanWP extra – Notice: Undefined index:’ is closed to new replies.