Support » Plugin: Better AMP - WordPress Complete AMP » Not Compatible with WPML

  • Hello,

    Looks like your plugin is not compatible with WPML. AMP version of Language URLs are not working properly. It is redirecting to random page on default language pages which is really bad for users and SEO.

    Example:
    domain.com is (default language page. i.e: English)
    domain.com/fr is a French home page created using WPML. But when we access this language page from AMP version (domain.com/amp/fr) it is redirecting to random pages in desktop version of default language page. Which is totally wrong.

    Is there any fix available?

    (Sorry can’t share our project website because of privacy issues).

  • The topic ‘Not Compatible with WPML’ is closed to new replies.