Support » Plugin: File Away » Nonce failed errors

  • now4dw

    (@now4dw)


    Good morning Thomas.

    This site displays an intermittent (dare I say random), ‘Nonce failed’ error message. I have not been able to replicate it but I have numerous screenshots from the client. It is not browser dependent and has occurred on all devices (desktop, tablet and mobile).

    The debug log reports the following:

    [18-Jul-2019 21:34:55 UTC] PHP Notice: Undefined index: is_safari in /home/u379715372/domains/logancitywhs.wiki/public_html/wp-content/plugins/file-away/lib/cls/class.fileaway_definitions.php on line 29

    The plugin is installed at network level. I will today activate it only at site level to see if that makes a difference but I am hoping you can provide some insight.

    Thanks in advance.

    DW

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author thomstark

    (@thomstark)

    Do you use SSL on your site? If so, is it enabled in the admin but not the front end? Are you forcing it at both ends?

    Hi again Thomas. The short answer is that I have tried and tested everything but keep coming back to FileAway as the root of the problem – but only because it is the ONE plugin that can’t be deactivated since it is THE key tool used on the site.

    Clearing the cache ‘seems’ to provide a temporary fix and I also suspect that the (front end) users of this site rarely close their browser.

    I use Hummingbird from WPMUDev as my caching tool but they have no reports of similar issues and they have also confirmed that my settings are correct. I also use Cloudflare but so do millions of others and I can’t find anything there.

    The mega challenge is that it is impossible to force the error. It simply occurs randomly. While I doubt that it will help you, the error message can be seen at https://screenpresso.com/=S2xWc

    Other active plugins on the site are:

    Classic editor (tested)
    Defender Pro (tested)
    Easy Sidebar Menu Widget (tested)
    Easy Theme and Plugin Upgrades (tested)
    Elementor/Elementor Pro (Tested)
    Heartbeat Control (tested)
    Hummingbird Pro (tested)
    MimeTypes Link Icons (tested)
    Native PHP Sessions for WordPress (recently added as a possible solution)
    Ocean Extra (tested)
    Ocean Hooks (tested)
    PDF Embedder (tested)
    Slimstat Analytics (tested)
    Smush Pro (tested)
    WP Better Attachments (tested)
    WPMU DEV Dashboard (tested)

    Note that when I say ‘tested’, no errors were reported when those plugins were deactivated but given the random nature of the error, I can’t be certain.

    Any suggestions or advice will be most welcome as this is consuming many hours and is getting the client offside 🙁

    Thanks in advance.

    Plugin Author thomstark

    (@thomstark)

    Well you shouldn’t be caching pages where the fileaway shortcode is used anyway. The file table is dynamic, not static.

    It’s caching your nonce, which is a security string generated based on the time and user, among other elements. That is stored in a script on the page.

    You need to tell your caching utilities not to cache pages where fileaway is in use.

    Thanks for the super-quick response Thomas! Hummingbird is set to only cache static content but perhaps it sees the FileAway content as static???

    I had previously deactivated it (Hummingbird) entirely and still had the error reported during that deactivation and actually reactivated it (at the client’s request) so that they could ‘clear the cache’.

    I’ll also remove the site from Cloudflare for a time and see if that helps.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.