Support » Plugin: Fields Framework » no usability

  • I tried to work with this plugin but the configuration is very hard and i can’t get my field on post editor. For me this plugin is rejected

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Naif Amoodi

    (@naifamoodi)

    Hi there.

    I’ll try my best to help you out!

    Are you using the builder or are you trying to create the sections and fields directly using the functions provided?

    Whatever the case, please post the code you have generated so far here: http://pastebin.com/

    you are very kind.

    i used the builder to create a group with three field and i would like to repeat them three at once and so on

    First i create the section (post), then i created the group. after that i pasted the code to my functions file but i can see only the group title and not the fields inside.

    Plugin Author Naif Amoodi

    (@naifamoodi)

    Hi,

    Can you please paste the code generated by the builder? It will become clear in a second if you could provide the code that has been generated.

    Have you added the three fields to this group you created?

    here you are
    http://pastebin.com/viyKrzMh

    i can’t understand how add my three fields

    thanks mate!

    Plugin Author Naif Amoodi

    (@naifamoodi)

    Ok looks like you have missed quite a lot there.

    You said you want three fields inside the group. You must first create these 3 fields and add them to the group.

    Take the following as an example:

    Let’s say you want three fields viz. A, B, and C. You want to group these fields into a field group named G. Then you want to add these to a section named P. The steps you would take for this would be as follows:

    Create a section named P. In your case you would be creating a Post Section by going to Builder -> Sections -> Post -> Create New

    Save & your section will be ready.

    Now you’ll create the three fields viz. A, B, and C. You would do this by going to Builder -> Fields. From there you’ll select the relevant type of field you are trying to create. So if you wanted ‘A’ to be a text field you’ll go to Bulder -> Fields -> Text -> Create New.

    Once these fields are created, you’ll create a group field called G by going to Builder -> Fields -> Group -> Create New. Over there, look towards the bottom and you’ll see a ‘Fields’ label. Here you’ll add fields of your choice to the Group. In your case you’ll be adding A, B, and C. Also if you want this Group to be repeatable, set Repeatable to yes.

    Once all this is done, go to Bulder -> Fields By Sections -> Create New and add field ‘G’ to section ‘P’.

    You should be done. Now just replace the code you added to functions.php with the new code generated by the builder.

    Please follow up and let me know how this goes.

    yeah, almost done.

    now i see what i wanted but there are still little issues.

    first of all i had to disable wp_enqueue_media() because it generated an error in backend, then, as you can see in the image posted, there are errors in the field.

    thanks for your help

    http://i41.tinypic.com/30cykc0.png

    Plugin Author Naif Amoodi

    (@naifamoodi)

    What error did wp_enqueue_media generate? Let me know and I’ll look into fixing it.

    Regarding the error in the image, do you get this on a completely new post too?

    Fatal error undefined function in …/php/classes.php line 648

    Yeah, it’s an empty page. Do you mean i have to load images with the content editor and then upload in the field?

    By the way, i’m working on a 3.4.1 wp version. I’ll update it asap

    Plugin Author Naif Amoodi

    (@naifamoodi)

    Thanks for bringing that into my notice. Looks like that function requires a version of WP greater or equal to 3.5.

    Because you are using a lower version of WordPress, you’ll manually have to upload media and then paste the URL to it. Or else you can do it by clicking on the field’s upload button.

    If possible, please paste your current code generated by the builder so that I can look into fixing the issue you talk about.

    here my currently code
    http://pastebin.com/xKB8dD8i

    then, when i write a content in a field, automatically it shows up on the frontend page?

    thanks

    Plugin Author Naif Amoodi

    (@naifamoodi)

    I just tried the code there and I don’t see any errors.

    You probably had set those fields set to be repeatable initially but later made them to be non-repeatable while they still had multiple values. I don’t see how else their values can be arrays.

    They won’t appear automatically on the user-end. You’ll need to modify your theme appropriately to display values from those fields.

    You can find details pertaining to functions used for retrieving values here: http://www.rhyzz.com/fields-framework.html

    An example for your case will be:

    $fields = ff_get_all_fields_from_section(‘group’, ‘meta’, ‘post’, $post->ID);

    echo ‘

    ';
    var_dump($fields);
    echo '

    ‘;

    You’ll probably add this to your theme’s page.php file.

    wow, you’re right, initially i did the fields repeatable. i changed them in the builder, how can i update that code?

    using this piece of code `
    <? $fields = ff_get_all_fields_from_section(‘group’, ‘meta’, ‘post’, $post->ID);
    var_dump($fields);
    ?>

    i get this error

    array(1) { [“group”]=> array(1) { [1]=> array(3) { [“title”]=> string(16) “Titolo Attività” [“textarea”]=> string(171) “Warning: htmlspecialchars() expects parameter 1 to be string, array given in /homez.379/lauracre/www/wp-includes/formatting.php on line 2666
    >” [“image”]=> NULL } } }

    probably it is due to the error in the backend

    Plugin Author Naif Amoodi

    (@naifamoodi)

    Whenever you make a change in the builder, new code is produced so you’ll need to replace the existing code in your functions.php file with the new one. But it seems you already took care of that.

    Now you just need to resave the effect pages.

    You are getting those errors message because those messages got saved as fields values. You populate them with appropriate values and it should be taken care of.

    i added my new content but nothing is changed http://www.lauracredidio.com/links

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘no usability’ is closed to new replies.