Support » Plugin: WP Awesome FAQ Plugin » No FAQ items?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    I have the same problem “No FAQ items. Please add some”.

    However mine has been working fine for the past 10 months with a list of 8 FAQ’s until I updated the plug in today…..

    http://www.chiropractictouch.co.nz/faqs

    Any advice would be greatly appreciated as I am unable to fix it.

    Thanks in advance

    Hi guys,

    I have also had this problem. I solved it by creating a new FAQ category (I called mine ‘all’) and added all of my FAQs to this category. I then changed the shortcode on my FAQ page to match the code the category gave me. e.g:

    [faq cat_id=”3″]

    Not an ideal solution, but it will work until this problem is fixed!

    Ellie

    Plugin Author Liton Arefin

    (@litonice13)

    Hello everyone,
    Let me check this. Will reach with you very soon.
    Thanks

    Hi Eli-g

    thank you, that suggestion worked and my faq’s are now back up and running.

    Interestingly I used the original (in my case) [faq cat_id=”10″] text to test it and no luck. As you said, by creating a new category [faq cat_id=”11″]and linking each FAQ item to it worked.

    Thanks again!

    The category ID was my problem, I just wrote an if else in index.php line 100. It’s working for me with and without categories.

    if( $cat_id == '' ) :
    	    $args = array (
    	            'posts_per_page'        => -1,
    	            'post_type'             => 'faq',
    	            'p'                     => $id,
    	            'order' =>"DESC"
    	        );
    	else:
    		$args = array (
    	            'posts_per_page'        => -1,
    	            'post_type'             => 'faq',
    	            'p'                     => $id,
    	            'tax_query' => array(
    		                array(
    		                    'taxonomy' => 'faq_cat',
    		                    'field'    => 'id',
    		                    'terms'    => array( $cat_id ),
    		                    ),
    		                ),
    
    	            'order' =>"DESC"
    	        );
    
    	endif;

    Perfect answer by AndrewAdcock… There wasn’t anything in place to support not having categories defined.. which was previously supported. I just copied and pasted his code right after

    // WP_Query arguments

    over the existing

    $args = array (
    	            'posts_per_page'        => -1,
    	            'post_type'             => 'faq',
    	            'p'                     => $id,
    	            'tax_query' => array(
    		                array(
    		                    'taxonomy' => 'faq_cat',
    		                    'field'    => 'id',
    		                    'terms'    => array( $cat_id ),
    		                    ),
    		                ),
    
    	            'order' =>"DESC"
    	        );

    And everything worked great!

    thanks everyone this helped a lot!

    Thanks @andrewadcock! That worked. Since you did the heavy lifting maybe the developer can release an update now so this thing will actually work.

    Plugin Author Liton Arefin

    (@litonice13)

    Hello All,
    Updated the Installation instructions. Hope it will help.
    Thanks

    @litonice13 I just downloaded the plugin and installed it on a vanilla WordPress installation but I’m still getting the same issue.

    The installation instructions lead me to believe that using the shortcode [faq] should show all posts, but the ‘No FAQ items’ error persists.

    Please let me know if I am missing something or if I can do anything to help resolve this. Thanks!

    Plugin Author Liton Arefin

    (@litonice13)

    Hello AndrewAdcock,
    I’ve updated the Plugin with your script. Hopefully everything is fine now.
    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘No FAQ items?’ is closed to new replies.