Support » Plugin: PhotoSwipe » No added data-size in wp multisite

  • Resolved pirro70

    (@pirro70)


    Howdy
    I found a weird behavior in a multisite environment:
    If I logged with superadmin privilege it is all ok but if I logged with Administrator (no superadmin) the:” add_action( ‘save_post’, ‘photoswipe_save_post’, 10, 3 )” doesn’t work, it don’t add the “data-size=…” in the link.
    Hope someone could help me.

    https://wordpress.org/plugins/photo-swipe/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Louy Alakkad

    (@louyx)

    Hi @pirro70,

    You’re right. This was an issue with something not clearly documented in WordPress. It’s solved now however. Can you please check the latest version?

    Regards,

    hi Louy Alakkad
    it doesn’t work but I found the problem.
    wordpress multisite use the “unfiltered_html” only for superadmin.
    For solving the issue I installed “Remove Kses” plugin and it work fine.
    You could implement this stuff in your plugin in order to avoid the installation of Remove Kses plugin.
    Another thing, you should enqueue jquery in

    if( is_singular() ) {
    		wp_enqueue_script(
    			'photoswipe-lib',
    			plugin_dir_url( __FILE__ ) . 'lib/photoswipe.min.js',
    			array('jquery'),
    			PHOTOSWIPE_VERSION
    		);

    because in some installation jquery load after photoswipe and it doesn’t work, so I have to load jquery from functions.php for ensure it load before photoswipe.

    Thanks for the plugin and excuse me for my english

    Plugin Author Louy Alakkad

    (@louyx)

    I see, I’ll fix KSES issue as soon as possible. another issue was in $wpdb->prefix which I solved earlier.

    As for jQuery issue, thanks for letting me know. I don’t know how I didn’t notice that 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No added data-size in wp multisite’ is closed to new replies.