Support » Networking WordPress » Multisite Frustration!!!

  • Resolved neogwebmaster


    Hi everyone,

    I’ve been combing through all the forums and I’m just not sure where to start. We’ve been using wordpress for our blog for about a year now and we want to create another blog using multisite.

    I am able to create a new site in the network, and I kept all the settings the same. I went to try and access the site and I get a blank page, so I checked to make sure the theme is network enabled, and it is. So I went to check the dashboard of the new site, and I get the error that it cannot find

    I’ve made sure that the plugins were disabled before I installed MS and I’m working off a Windows 2008 server.

    Any idea’s where to start to look for the issue?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I forgot to add that I can navigate to the new site I get a blank page. So I’m not sure if the theme is applying to the subsite or not.

    I’m using the Atahualpa Theme By BytesForAll, Version 3.7.11

    To get this straight, you have installed WordPress within a sub-folder named “blog” within the root of your domain? It’s been there a year and now you have recently enabled multisite and added a second site which resides in “subfolder” and you cannot access it?

    Is this the latest version of WordPress (3.5.1)? Are you sure all plugins are disabled. If they are network enabled, they are going to be active on all sites. By default, the default theme (Twenty Twelve or Twenty Eleven) will be enabled. Did you happen to deactivate the default theme?

    You may want to start over, either delete the new site and add it again or add a third site. Carefully confirm each step long the way. Do it with all plugins disabled and using the default theme. Change one variable at a time and preview the site at each step along the way. If that fails, enable debug and browse the error logs for clues. Good luck.

    You are correct in your assessment.

    I am on the newest wordpress, plugins are disabled.
    I did go back and try and create another new site, and it worked once I changed the theme in the settings to the correct theme. EXCEPT I still cannot access the dashboard for either of the new subsites.

    I get the error the page is not redirecting properly for both of the new sites. Any idea’s?

    How are you trying to access the dashboard of the sub-site? Via the ../my-newsite/wp-admin url? Try to see if you can access it via the backend, via the network admin menus.

    Do you have a redirect plugin installed? Have you made any edits to your .htaccess file?
    Here is what the default multisite .htaccess looks like:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /worship/
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Yours may include additional rules if you have installed a caching plugin like W3 Total Cache or SuperCache.

    I have tried to access it through both ways and I get the same error.

    All plugins are disabled currently so I don’t know if that is affecting this either.

    I’m on a windows server so I don’t have a htaccess file. Is there another file I should be looking for on a windows server?

    Yes, of course there is no .htaccess file on a Windows server and there is your problem. Fortunately there is a resolution. This is all the same problem as this other topic:

    If you’re using IIS and don’t have apache and mod-rewrite, you need to modify your web.config file.



    IMHO, WordPress works best on on a LAMP stack (Linux, Apache, MySQL and PHP), so I personally avoid Windows servers if I can. Linux is simply less expensive, more secure, better performing, and easier.

    Hi littlenfiesty
    I had the same problem and the guys of Hostgator solved it. In my case the problem was that the document root for the wildcard subdomain was pointing at the wrong location.
    In my case the the wildcard is: *
    and th document root It has to be: public_html/

    Because is not the primary wp installation.

    Try this, for me it works perfectly.

    Good luck

    Update guys!!! I finally figured out it was one of my plugins along with the wrong coding in my webconfig files. I got the answer from..

    If you’re using IIS and don’t have apache and mod-rewrite, you need to modify your web.config file.



    Now everything is working. It even fixed my other issue of the blog slug from this post…

    Thank you for everyone’s help!! I hope the above links and information helps someone else.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Multisite Frustration!!!’ is closed to new replies.