WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] remove blog slug (9 posts)

  1. littlenfiesty
    Member
    Posted 1 year ago #

    I just installed multisite, and I've set up a second site. But my main site is http://www.domain.com/blog and now when I go to any of the links the lings have http://www.domain.com/blog/blog/article

    I want my subsite to be http://www.domain.com/blog/subdomain

    How do I remove the slug from the main site?

  2. Ed Gray
    Member
    Posted 1 year ago #

    From Ipstenu on "Best way to remove /blog slug Wordress 3.4 Multisite"
    JUNE 17, 2012:

    Edit the site via network admin -> sites

    Click on settings and scroll till you find the permalink settings.

    Remove "blog".

    Now bear in mind, should you ever change permalinks on the main site, you will have to go back and do that again.

    ----
    This works on 3.5 as well. The reason that the "blog" slug is present in the first place is to avoid possible conflicts with your secondary sites and categories. For example, you have a post on the main site with a slug called "hotdogs" and then you have a secondary site or category named "hotdogs" you will have a conflict. Just something to be aware of.

  3. littlenfiesty
    Member
    Posted 1 year ago #

    Now the page title in the "tab" says "Page not found >> article" but it finds the page fine. Should I just wait a bit for things to update?

  4. littlenfiesty
    Member
    Posted 1 year ago #

    BTW it did fix the blog/blog/ issue...THANK YOU!!!

  5. littlenfiesty
    Member
    Posted 1 year ago #

    Darn it...now that I went back and checked further...yes that did fix the blog/blog/ issue but NOW the permalinks do not go to the article and the page title still reads "Page not found >> article".

    Any ideas?

  6. Ed Gray
    Member
    Posted 1 year ago #

    Can you share a link to this site? Are you talking about using a pre-existing link to a page that has "blog" within the url address? You may need to create a redirect rule that allows you to use pre-existing urls to navigate to older pages that had "blog" in the url.

  7. littlenfiesty
    Member
    Posted 1 year ago #

    I got it figured out. One of my plugins was causing another error and once I disabled the plugin I could change the permalink and it updated correctly!

    Not to self...ALWAYS CHECK YOUR PLUGINS!!! Thanks for your help Graynotgrey...you got me pointed in the right direction!

  8. mairaj
    Member
    Posted 1 year ago #

    What plugin was that? I'm facing similar problem.

    Thanks

  9. littlenfiesty
    Member
    Posted 1 year ago #

    The plugin that gave me my issue was the WordPress Protectin Lite plugin. But I deactivated all them and turned them on one by one to see when the issue happened. Thats when I discovered which one it is.

    If you are having the same issues deactivate all your plugins and then activate them one by one until you find the one that gives you the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic