Support » Networking WordPress » Multisite: Can't change upload limit

  • Resolved EverythingTech

    (@everythingtech)


    I’ve increased the upload_max_filesize and post_max_size for PHP all the way to 100MB, added define('WP_MEMORY_LIMIT', '100M'); to my wp-config.php, and changed Max upload file size to 100000 (KB) in Network Admin > Settings > Network Settings, but the Add Media page still says the limit is 10MB. What gives?

    You can check out my PHP config here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    File limit has nothing to do with memory limit 🙂

    max_file_uploads is 20 in your PHP config. That should be 20M but ask your host how to set that correctly.

    It’s my understanding that max_file_uploads is the number of items that can be uploaded at the same time. http://allinthehead.com/retro/349/the-curse-of-max_file_uploads According to this thread, memory limit is related to file uploads (possibly because it has to store the file in memory before it saves it to the disk, but that’s just a guess).

    This guy is suggesting I modify something in the database, but it seems to me like that should be the value that is changed on the Network Settings page in the Dashboard.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Memory is how much memory PHP gets to handle uploads. In THIS instance, what you are seeing on Add Media is 100% unrelated. Put it aside for now 🙂

    That 10MB on Add Media directly relates to how big a file PHP allows. That’s set via upload_max_filesize in PHP, and yes, yours is 100M but that’s not picking up, which MAY mean there’s an issue with permissions and how your server allows that.

    Who’s your webhost? Have you asked them how to change that?

    This guy is suggesting I modify something in the database, but it seems to me like that should be the value that is changed on the Network Settings page in the Dashboard.

    That guy is wrong 🙂 You have already made the needed change on /wp-admin/network/settings.php

    The odds are it’s a quirk of your webhost.

    I suppose I should mention that the problem was indeed solved by contacting my host. They did something on their end and it was solved instantly. Thanks!

    Here’s the tricky part – you have to increase BOTH the post_max_size in PHP settings, as well as upload_max_filesize

    I’m pretty sure I did both. As I mentioned, the problem was solved by my host.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Multisite: Can't change upload limit’ is closed to new replies.