WordPress.org

Ready to get started?Download WordPress

Forums

How to increase the max upload size (17 posts)

  1. tjoge011
    Member
    Posted 5 years ago #

    Hi,

    I am trying to upload a media file, but I am stopped because the max upload size is 24mb. How do I increase this size? I have changed in Wampserver's php.ini file but this did not solve my problem.

  2. stvwlf
    Member
    Posted 5 years ago #

    increase PHP's file upload limit.
    In php.ini file, change the parameter to whatever size you need (example: )
    upload_max_filesize = 32M

  3. tjoge011
    Member
    Posted 5 years ago #

    Thanks... Where do I find php.ini file?
    I have one on my public-html folder on siteground. This I have changed but I still cannot upload more that max 24MB..

  4. Samuel B
    moderator
    Posted 5 years ago #

    add this to top of wp-config.php
    define('WP_MEMORY_LIMIT', '64M');

  5. tjoge011
    Member
    Posted 5 years ago #

    What does the below highlighted message have to do with WP_MEMORY_LIMIT?

    This file is too big. Your php.ini upload_max_filesize is 24

    I need to know where the php.ini file supposed to be saved. I have changed the upload_max_filesize, but still does not work.

  6. Samuel B
    moderator
    Posted 5 years ago #

    what I gave you works for memory and file size
    don't use it
    what do I care?

    talk to your host if you can't locate the correct php.ini and they can bump it for you

  7. whooami
    Member
    Posted 5 years ago #

    additionally, you really ought to change the max post size .. but hey.. I dont care either :P

  8. tjoge011
    Member
    Posted 5 years ago #

    Isn't PHP.INI a part of WP installation? Can you, Samboll or whooami, tell me in which directory you have this file saved? public-html/wp-admin, public-html/wp-content or where?

  9. kira002
    Member
    Posted 5 years ago #

    PHP.INI is located on your server, tjoge011. You'll need SSH access to edit it, or ask your hosting provider if they can do it for you.

  10. Samuel B
    moderator
    Posted 5 years ago #

    no - php.ini is a host file
    should have one in root or above root - not in wp install
    however, some hosts keep this file hidden and you will need them to do the action for you

    did you try the wp-config.php code I gave you?

  11. tjoge011
    Member
    Posted 5 years ago #

    OK, Thanks for you help and info. I have contacted my host,SiteGround, and here is their answer:

    Unfortunately the upload_max_filesize setting cannot be changed on the shared hosting servers. The resources are shared among all users. They are set for the best performance.

  12. WebTechGlobal
    Member
    Posted 5 years ago #

  13. D M
    Member
    Posted 4 years ago #

    To samboll...

    I inserted the "define('WP_MEMORY_LIMIT', '64M');" you suggested into my wp_config.php file and it made no difference.
    Any other suggestions?

  14. henkholland
    Member
    Posted 4 years ago #

    Yeah, don't confront your visitors with such big files? And or host them at youtube etc.

  15. bh_WP_fan
    Member
    Posted 4 years ago #

    EloquentBohemian look for the setting in your wp-settings.php and change it there, or see if you are able to change your php.ini as previously mentioned.

  16. adam_g2000
    Member
    Posted 4 years ago #

    I think I have the solution to this for you - even through it may seem a little late others searching for the issue who find this may be helped.

    The issue does lie in the php.ini file, but in two places.1

    upload_max_filesize

    and

    post_max_size

    Increase these both and you should be right.

  17. Will White
    Member
    Posted 4 years ago #

    adam_g2000

    I used your advice:

    Make a blank text file. Save As php.ini

    Inside the text file copy-paste the following:

    upload_max_filesize = 32M
    post_max_size = 32M

    Load the php.ini file into the folder you've set up your website. I put mine in the same folder I have WP installed so it doesn't affect my whole site.

Topic Closed

This topic has been closed to new replies.

About this Topic