• Resolved Dubsy

    (@dubsy)


    I originally posted about this in the general forum but I’m now being directed towards jetpack for a solution.

    I’ve recently migrated my website to a new host and changed from non ssl to ssl with a dedicated IP. While I installed all fresh copies of WordPress and associated plugins, I reinstalled a backed version of the SQL database (using drop tables and create tables). I did not have this issue before migrating.

    My only kink with my migration appears to be related to the “After the deadline module”. When clicking on update on my existing posts (or publishing a new post), I get the following 400 error.
    “wp-admin/admin-ajax.php?action=proxy_atd&_wpnonce=1fe627c361&url=/checkDocument”

    Through further investigations (trial and error), I have discovered that when I turn the “proofreading” feature in Jetpack off the error goes away. Which is not really ideal as I’d like to use this feature.

    I’m not sure what to do to fix this so any help would be greatly appreciated. (I have tried turning the feature on and off and also searching through my SQL database for anything related, but I wasn’t sure what I was searching for etc and didn’t find anything illuminating).

    This is my initial post where someone directed me towards a firewall issue: https://wordpress.org/support/topic/404-admin-ajax-php-error-url-checkdocument/

    And this is my post over at AIT (who I use for security) who directed me towards Jetpack’s ‘After the deadline issue.’ : https://forum.ait-pro.com/forums/topic/malformed-syntax-admin-ajax-possibly-firewall-issue/

    Hope someone can help.
    Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That call is indeed made by Jetpack’s spellchecker feature. If you use the most recent version of Jetpack it should work out of the box, but obviously something is blocking that call on your new site.

    I ran a few extra tests on your site, and it seems that some of our requests are blocked by your security plugin, Bulletproof Security. Here is the response we get when we try to make XML-RPC requests and communicate with your site from some of our servers:
    https://gist.github.com/jeherve/e64e3486ad3d940b49a9690f46e68cdf

    When we try to push data to your site, still via XML-RPC, the response still fails but is a bit different:
    https://gist.github.com/jeherve/f6236065260e955d6243e730d239b9a0

    The bpsMessage container added around the message tells me that page is also outputted by Bulletproof Security.

    Could you try to play with your Bulletproof Security settings and see if you can find something to unblock those requests? That should help!

    Thread Starter Dubsy

    (@dubsy)

    I removed some custom .htaccess code regarding the XML-RPC which apparently had become redundant over the years (I found some other posts on their forum about this issue from a few months ago). This may have caused the response you received. I’ve run the Jetpack debug and it says the connection is fine, but I’m still getting the 400 error above.

    I’ve also received this error:
    [21-Oct-2017 08:05:05 UTC] PHP Warning: DOMDocument::loadHTML(): htmlParseEntityRef: expecting ‘;’ in Entity, line: 1 in /home/sellmyda/tinadubinsky.com/wp-content/plugins/jetpack/json-endpoints/jetpack/class.jetpack-json-api-plugins-endpoint.php on line 214

    And WordPress.com which has the site listed is saying I’m not the site’s owner. 🙁

    • This reply was modified 6 years, 8 months ago by Dubsy.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I’m afraid the problem is still the same; I still receive the same responses from your site.

    What happens if you deactivate Bulletproof Security altogether and remove custom rules it may have added to your /.htaccess file?

    I’ve also received this error:
    [21-Oct-2017 08:05:05 UTC] PHP Warning: DOMDocument::loadHTML(): htmlParseEntityRef: expecting ‘;’ in Entity, line: 1 in /home/sellmyda/tinadubinsky.com/wp-content/plugins/jetpack/json-endpoints/jetpack/class.jetpack-json-api-plugins-endpoint.php on line 214

    That’s something we’ll get fixed in the next release:
    https://github.com/Automattic/jetpack/pull/7919

    WordPress.com which has the site listed is saying I’m not the site’s owner.

    That’s most likely because of the errors we get from your site when trying to communicate with it.

    Thread Starter Dubsy

    (@dubsy)

    I deactivated it, removed the custom rules and put in a standard .htaccess and I’m now getting a general 404 error.

    I’ll go through and remove all plugins and change the theme and see if the error persists.

    I was concerned that changing my Akismet account could have triggered something (I now have two Akismet license accounts one for my non-hobby sites and one for my hobby sites).

    Shall let you know how I go.

    • This reply was modified 6 years, 8 months ago by Dubsy. Reason: was a 400 error, now a 404
    • This reply was modified 6 years, 8 months ago by Dubsy. Reason: updating information
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I deactivated it, removed the custom rules and put in a standard .htaccess and I’m now getting a general 404 error.

    The good news is, we don’t get blocked by Bulletproof Security anymore.

    The bad news is, I still get errors when I try to communicate with your site. I think your host might have security rules in place that block us.

    Let me know how it goes when deactivating other plugins; Akismet won’t play a role in this though, no need to worry about it.

    FYI – cPanel added Mod Security as a new standard feature back around January 2017. So what we suspect is happening is that as web hosts worldwide upgrade cPanel to the new cPanel version that includes the Mod Security feature then the Mod Security SecRules and/or SecFilters that have been created by default by cPanel for Mod Security are causing various problems for BPS, WordPress, other plugins, etc.

    We have seen a wide range and numerous issues and problems with cPanel Mod Security SecRules/SecFilters over the last 10 months. Most web hosts are either allowing users to edit Mod Security SecRules/SecFilters or will edit Mod Security SecRules/SecFilters for users or on some web hosts cPanel Mod Security only has Enable/Disable capability.

    • This reply was modified 6 years, 8 months ago by AITpro.
    • This reply was modified 6 years, 8 months ago by AITpro.
    • This reply was modified 6 years, 8 months ago by AITpro.

    The quickest way to determine if Mod Security is causing an issue/problem is to check the server logs for Mod Security log entries.

    Thread Starter Dubsy

    (@dubsy)

    Hi,

    I’ve been back and forward in communications with my webhost most of the night and they are now saying they have fixed the issue. I no longer get the 404 when posting.

    When I run the debugger from inside website though, on the second attempt I’m still getting the can’t connect with Jetpack message (I have cleared my cache and cookies).

    I was wondering if you were able to see if you can connect now from your end?

    The issue was ModSecurity (unfortunately my host doesn’t allow me access to change these, so I have to go through them which can be a long process to get it all right).

    Cheers
    -Tina

    • This reply was modified 6 years, 8 months ago by Dubsy.
    Thread Starter Dubsy

    (@dubsy)

    I’m not sure what to make of this but I’m sure you have an idea. I’m still getting intermittent connection problems, between 50-70% of the time it connects and the other time it tells me there’s a problem. For my host when they tested they had a 100% success rate, I was only having 50% success.

    When I look at the debug info when it fails, I see this:

    TEST RESULTS:

    HTTP: PASS
    HTTPS: PASS
    IDENTITY_CRISIS: PASS
    SELF: FAIL

    The fail means something isn’t working – maybe at my end – but I’m not sure what. I use Kaspersky for my own personal computer firewall so I don’t know if that would have an impact. Otherwise, I use Chrome 64 bit. I kind of grew a little impatient today (all my own fault – unfortunately, it’s a live site and I don’t like to leave it down for too long) and began reinstalling my plugins. I also took the opportunity to install a new Woocommerce theme with Woocommerce. I’ve still not activated BPS Pro. The 50% failure rate started before I began re-adding my plugins. I’ve had more failures with the debug since activating the plugin, Flamingo (but also a success too ) so not sure if there is also a plugin conflict since it’s not consistent.

    • This reply was modified 6 years, 8 months ago by Dubsy. Reason: grammar
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I still see some issues as well, so I wonder if there are still ModSecurity rules that may catch some of our requests. Could you ask your host to take another look? I would recommend that they check rules that may catch system.multicall XML-RPC requests first.

    Let me know how it goes.

    Thread Starter Dubsy

    (@dubsy)

    Hi Jeremy,

    They came back to me after the sending your suggestion telling me it should all work now, but I’m still getting a FAIL (2 out of 3 attempts failed) on the last test. (I notice a few others have posted a similar issue in September but not what resolved it for them.) I’ve sent them a copy of the FAIL portion of the debug script hoping this might point them toward something else that’s blocking the connecting.

    Cheers
    -Tina

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Things do seem to work a bit better now.

    Could you now go to WordPress.com and try to interact with your site from there (editing posts, viewing stats, viewing site settings, …)
    https://wordpress.com/posts/

    Let me know how it goes.

    Thread Starter Dubsy

    (@dubsy)

    Looks good and I’ve reactivated my plugins including BPS without seeing any issues so far.

    Thanks for all your help Jeremy (and AITPro too!).

    Great! Glad you got this figured out. Another general FYI for intermittent issues/problems: Intermittent problems or problems that start happening all of a sudden are typically going to be related to things like: php memory/cache/caching plugins/CDN’s/VPN’s/Proxy’s/Load Balancers/Host server problems (new security measures added on Host server, DNS server/DNS configuration problem, MySQL server timeout, server overloaded, etc.), Browser problems (corrupt cache, Sessions, Cookies, add-on, extension)/ISP (connectivity)/CloudFlare, Incapsula, etc.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘malformed syntax.’ is closed to new replies.