Support » Plugin: BuddyPress Activity Plus » Links and Videos Not Posting

  • This is a handy plugin to have on a WordPress 4.4.2 / BuddyPress 2.5.0 site. The BP Activity Plus version is 1.6.4.

    Was testing the plugin in a development environment. Adding images works like a charm. However, I cannot get it to work when trying to create an activity post with links or videos from subscriber accounts. As an admin, I was able to post links and videos but not from the subscriber test account.

    Any idea what might be the problem?

    https://wordpress.org/plugins/buddypress-activity-plus/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey there dhsllc,

    Hope you’re well today!

    This is a known issue and it should be related to BuddyPress and not Activity Plus plugin. I’ve found a solution for the link sharing issue in another thread. You can check it out here:

    https://wordpress.org/support/topic/links-not-work-with-image?replies=3#post-6638632

    Please let me know if this helps 🙂

    Cheers,
    Bojan

    This fix in the link above works great! Thanks.

    Another question…. When you view the links posted in the activity stream as a logged in user it shows as a smaller thumbnail left and the link and preview article to the right. When you view the activity stream logged out the thumbnail is a nice big image (I assume set by the width in settings) and the article and link under it. This looks so great! Is there a way to have it view like this with the larger image even for logged in users?
    You can have a look here: https://parttimegolf.com/activity/
    (you’ll have to create an account to see it as a logged in member… if you golf sign up!!

    Thanks,
    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again Troy,

    Could you please open a new thread in the future in case your question in not related to the one from thread opener? This way we don’t spam the person who opened this thread and also make your issue easier to search to in case somebody else has the same issue.

    Since you already posted here I’ll respond as well.

    I’ve checked your site and I can definitely see the difference. You should be able to override it with some custom CSS. Please try adding the following CSS code in the style.css file of your child theme or if your theme doesn’t have custom CSS tab add it in your site using the following plugin:

    http://wordpress.org/plugins/simple-custom-css

    .bpfb_final_link .bpfb_link_preview_container {
        width: 100%;
        height: auto;
    }
    
    .bpfb_final_link .bpfb_link_preview_container img {
        width: 100% !important;
    }

    Normally I wouldn’t suggest the use of the !important declaration. However, it can sometimes be a necessary evil when over-writing existing styles. You can find more info on the use of important declaration here:

    https://developer.mozilla.org/en-US/docs/Web/CSS/Specificity#The_!important_exception

    Hope this helps 🙂

    Cheers,
    Bojan

    Bojan, thank you so much that solve the problem. The videos and images are now showing.

    I too am seeing the issue Troy reported with the stream showing a thumbnail for the image vs the big image and the video shows wide and narrow.

    I tried adding the code you provided to Troy but it didn’t work for me.

    Thanks in advance for your help.

    Cynthia

    Yes. Sorry for combining this in the thread.

    The CSS works great! Thanks!!
    Two other things…
    Is there a way to not have the ‘Read more’ display when the preview text is past a certain amount of characters? It displays funny and if you clicked it acts funny. It doesn’t really need to be there as the user is clicking on the thumbnail or link to read more. (I have this opening in another tab)

    The other is the preview text doesn’t scale at a certain point. If you just scale your browser window to mimic a mobile screen you can see it. At a certain point it get cut off. (also you will see where the ‘read more’ gets formatted weird here too)

    Your help is GREATLY appreciated!

    Troy

    ps… are you a golfer at all? If so, I’ll send you out your bag tag and stickers for joining.
    If you’re not I can delete your account.

    Troy

    @dhslic what do you have your images sizes set at in settings for the plugin.
    I have all of mine set to 450px. Might solve your issue.

    Troy

    Hi Troy, in the “buddypress activity plus” settings, I too have it at 450 px.

    I cleared cache and even checked in a new browser but the thumbnail still shows up.

    Oh bummer. Perhaps something in your theme is overriding the css no matter what.

    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey guys,

    @troy both of your issues can be fixed with some custom CSS.

    To remove the the read more link there you can add the following CSS code as described above:

    .activity-read-more a {
        display: none;
    }

    In relates to content not being completely responsive that’s because of the layout your theme has and activity content having fixed width. We can simply set maximum width to be 100% of the container so the content shrinks when the window size is smaller then its actual width. To do this please try adding the following:

    .bpfb_final_link .bpfb_link_contents {
        max-width: 100%;
    }

    ps… are you a golfer at all?

    No I am not a golfer, feel free to remove my account from your site 🙂

    @cynthia please post link to your site and keep the code added so I can take a look? Also please let me know if I can register to your site as well. And lastly let me know where exactly are you adding the code?

    Cheers,
    Bojan

    The ‘read more’ fix worked perfectly!
    I still have an issue with the text contents not wrapping correctly but I think it is a theme layout issue I need to address for the buddypress activity stream when viewed on mobile or small screens.

    Thanks for great support Bojan!

    Troy

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again Troy,

    Glad I could help, I double checked this on your site and I can’t see the issue on smaller resolutions, the code is being properly applied and it doesn’t go out of a window. Please see screenshot http://screencast.com/t/6Lzwp7l0SjK.

    Cheers,
    Bojan

    Bojan,

    I did see that the code is working perfectly. I had to clear my cache plugin… I always forget about that dam thing!

    Again… thank you for truly great support!

    Troy

    ps. i’ve had a few comments that it would be nice to have labels next to the icons. some users are clueless and don’t know that the link icon is for posting a link. maybe in a future update that could be a setting option.

    Hi there, Bojan you are awesome.

    The dev environment is here: http://dev2.kiringie.me/.

    You can create a test account by clicking on the top right plus sign.

    I am adding the CSS code under > appearance > customize > custom > CSS

    Thanks for your help.

    Cynthia

    Plugin Author Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey Cynthia,

    I’ve created an account on your site in order to see the logged in/out thumbnail thing but I can’t check the activity page as you need to approve my account. I’ve registered as (username: bojanwpmu).

    Please let me know when I can check your site.

    @troy

    ps. i’ve had a few comments that it would be nice to have labels next to the icons. some users are clueless and don’t know that the link icon is for posting a link. maybe in a future update that could be a setting option.

    This can be easily achieved with some custom CSS and by adding after element with some text. For example adding the following CSS code:

    #bpfb_addLinks {
        min-width: 45px;
        overflow: visible;
        background-position-x: center;
    }
    
    a#bpfb_addLinks:after {
        content: "Link";
        display: block;
        margin-top: 30px;
        text-align: center;
        font-size: 17px;
    }

    Would result in the following http://screencast.com/t/B2CVCIMtkdK4.

    Cheers,
    Bojan

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Links and Videos Not Posting’ is closed to new replies.