Support » Plugin: appear.in WP » jQuery dependancy

  • Hi UaMV!
    Thank you for your usefull plugin.

    Even if I’m french I will try to expose you my trouble/resolving in a sort of english.
    When I use your plugin directly in my WP project, I have a classical error type : “jquery is not defined”.

    In “appear-in-wp.php” on lines 176 to 182, I see jquery enqueueing then 2 scripts jQ-dependants. When I comment line 176 (jQ enqueue) and I add ‘jquery’ in the both next enqueueing function, the trouble is resolved.

    ex.
    wp_enqueue_script( 'aiwp', AIWP_DIR_URL . 'aiwp.js', array('jquery'), AIWP_VERSION );
    instead of
    wp_enqueue_script( 'aiwp', AIWP_DIR_URL . 'aiwp.js', array(''), AIWP_VERSION );

    I think that depend on project, but that could be an idea to make a hooks or shortcode option like “already_load_jq=true|false” or something like that.

    Thank you for your time.
    Regards.

    ps. I’m beginner on WP, if I do something wrong, just say me 🙂

Viewing 1 replies (of 1 total)
  • Plugin Author uamv

    (@uamv)

    This is great. Thanks for the report. I’ll check it out and try to patch it soon.

Viewing 1 replies (of 1 total)
  • The topic ‘jQuery dependancy’ is closed to new replies.